Here is the test I'm using to check the correctness of sys_select. It
is a subset of test-poll.c.
Ok?
Paolo
/* Test of substitute.
Copyright (C) 2007, 2008 Free Software Foundation, Inc.
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
According to Bruno Haible on 8/30/2008 6:39 AM:
> Hi,
>
> The documented open() bug on Solaris [7-9] and HP-UX 11.00 exists also as a
> bug in fopen(). I'm applying this to fix it:
> * lib/fopen.c (rpl_fopen): Return NULL if the mode specifies
Hi Eric,
> > - In the configuration test, keep room to both sides of the ss_sp value.
> > On IRIX, we don't want the test to crash. We want it to exit(1)
> reasonably.
>
> We need to do this consistently, then. The subsequent configure check
> (whether
> longjmp works from a stack overf
Eric Blake byu.net> writes:
> Here's the minimal patch needed to CVS libsigsegv to expose the bug, as
> well as work around it for Irix 5.3. I still need to port something like
> this for c-stack in the non-libsigsegv case.
Now that libsigsegv is cleaned up, here's what I'm applying to gnulib.
> In this case, the tradition is that the gnulib module
> name is named after the function and not the header file, though, so
> possibly you could rename sys_select to select? Maybe it is not worth
> the breakage though, you decide.
Maybe later. I also think it should be renamed, but I'm not su
Paolo Bonzini <[EMAIL PROTECTED]> writes:
>> the stdio module [...]
>> does not pull in the fopen module, even though the fopen module
>> makes fopen function work *the way anyone including stdio.h would
>> expect them work*.
>
> I disagree on the "anyone" part. I never missed the fopen module, b
Paolo Bonzini <[EMAIL PROTECTED]> writes:
> Simon Josefsson wrote:
>> Paolo Bonzini <[EMAIL PROTECTED]> writes:
>>
>>> This revised patch includes the select(2) wrapper in sys_select,
>>> not sys_socket. This makes sense given the very purpose of the
>>> wrapper -- which is to let the client use
Simon Josefsson wrote:
> Paolo Bonzini <[EMAIL PROTECTED]> writes:
>
>> This revised patch includes the select(2) wrapper in sys_select,
>> not sys_socket. This makes sense given the very purpose of the
>> wrapper -- which is to let the client use select for other descriptor
>> types than socket
> the stdio module [...]
> does not pull in the fopen module, even though the fopen module
> makes fopen function work *the way anyone including stdio.h would
> expect them work*.
I disagree on the "anyone" part. I never missed the fopen module, but
I'm sure everyone who wrote cross-platform soc
Paolo Bonzini <[EMAIL PROTECTED]> writes:
>>> The difference is that without these fixes, winsock is simply just too
>>> crippled for the casual Unix programmer. Providing sys/socket.h and
>>> sys/select.h without anything like these wrappers was just giving a
>>> false sense of portability.
>>
>> The difference is that without these fixes, winsock is simply just too
>> crippled for the casual Unix programmer. Providing sys/socket.h and
>> sys/select.h without anything like these wrappers was just giving a
>> false sense of portability.
>
> I think that is consistent with how gnulib wo
Paolo Bonzini <[EMAIL PROTECTED]> writes:
> This revised patch includes the select(2) wrapper in sys_select,
> not sys_socket. This makes sense given the very purpose of the
> wrapper -- which is to let the client use select for other descriptor
> types than socket handles.
Btw, if you didn't li
This revised patch includes the select(2) wrapper in sys_select,
not sys_socket. This makes sense given the very purpose of the
wrapper -- which is to let the client use select for other descriptor
types than socket handles.
I do believe that the code belongs in the generic "header file"
modules,
Paolo Bonzini <[EMAIL PROTECTED]> writes:
>> Compare other header files and system
>> functions for how to do it, e.g., stdio.in.h and fopen: the replacement
>> for fopen isn't pulled in by the stdio-h module normally, but the
>> stdio.in.h code helps the fopen module when in use.
>>
>> Possibly
> I don't think this code should be built just because someone wanted the
> sys/socket.h header and added the sys_socket module. There are many
> places you want the sys/socket.h header without calling select.
Ok, I'll place it into sys_select instead.
> Compare other header files and system
>
Bruno Haible clisp.org> writes:
> > Here's the minimal patch needed to CVS libsigsegv to expose the bug, as
> > well as work around it for Irix 5.3.
>
> Nice work! I'm applying this only slightly modified version.
> - In the configuration test, keep room to both sides of the ss_sp value.
>
Paolo Bonzini <[EMAIL PROTECTED]> writes:
> Simon Josefsson wrote:
>> Paolo Bonzini <[EMAIL PROTECTED]> writes:
>>
>>> Tested together with patch 3/3. Ok?
>>
>> I haven't tested it, but will do now that it has been installed.
>>
>> However, just to confirm, the sys_socket module needs to remai
Paolo Bonzini <[EMAIL PROTECTED]> writes:
> Tested under Wine. I'd appreciate more testing before committing it.
I don't think this code should be built just because someone wanted the
sys/socket.h header and added the sys_socket module. There are many
places you want the sys/socket.h header wi
Simon Josefsson wrote:
> Paolo Bonzini <[EMAIL PROTECTED]> writes:
>
>> Tested together with patch 3/3. Ok?
>
> I haven't tested it, but will do now that it has been installed.
>
> However, just to confirm, the sys_socket module needs to remain
> LGPLv2.1+, and that's what the module descriptio
Paolo Bonzini <[EMAIL PROTECTED]> writes:
> Tested together with patch 3/3. Ok?
I haven't tested it, but will do now that it has been installed.
However, just to confirm, the sys_socket module needs to remain
LGPLv2.1+, and that's what the module description says, did you intend
this for the wi
> The rpl_close wrapper in winsock.c will collide with the one in fchdir.c.
> We can work on it after you commit your patch.
I'll leave this to you...
> Also, I would like to have select() implemented right, as I need it in the
> 'msgfilter' program. But that's also for afterwards.
... as a deal
Here is the patch to recycle some of the code in poll.c (much less
than I expected) to implement select(2). The code duplication between
the files is limited to one function (win32_compute_revents vs.
win32_poll_handle); should I add a note that changes to one should
be replicated in the other?
H
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
According to Bruno Haible on 9/23/2008 5:25 AM:
>> In an effort to unify this behavior, I was considering making m4 1.4.12
>> pre-reject directories with EISDIR
>
> Then I would split the fopen() call into open() + fdopen(), and use fstat()
> between
Eric Blake wrote:
> The use case where I discovered this bug was with m4 1.4.11. Compare:
>
> mingw$ m4 .
> m4.exe: .: Permission denied
> Linux$ m4 .
> m4:/:1: Read error
> OpenBSD$ m4 . && echo done
> done
> EMX$ m4 .
>
>
> In an effort to unify this behavior, I was considering making m4 1.4.
Hi Paolo,
Thanks for this big step ahead!
In set_winsock_errno, I think we also need to convert the three possible error
values below 100. See
http://lists.gnu.org/archive/html/bug-gnulib/2008-09/msg00136.html
http://msdn.microsoft.com/en-us/library/ms740668(VS.85).aspx
The rpl_close wrapper
Pushed, it was preventing my daily build from completing:
ERROR: files left in build directory after distclean:
./gltests/t-perror1.tmp
./gltests/t-perror3.tmp
./gltests/t-perror.tmp
./gltests/t-perror2.tmp
make[1]: *** [distcleancheck] Error 1
/Simon
---
ChangeLog|5 +
test
Bruno Haible <[EMAIL PROTECTED]> writes:
> Hi Eric,
>
>> Like so. Bruno, okay to apply?
>
> Thanks for the analysis. The patch is nearly perfect. Only the change of the
> 'precision' variable from 6 to 0 comes a bit too late: by this time, its
> value 6 has already been used for computing the siz
27 matches
Mail list logo