> Acked-by: Matthew Brost # for Xe
> Reviewed-by: Boris Brezillon # for Panfrost
> and Panthor
> Reviewed-by: Christian Gmeiner # for Etnaviv
> Reviewed-by: Frank Binns # for Imagination
> Reviewed-by: Tvrtko Ursulin # for Sched
> Reviewed-by: Maíra Canal # for v3d
Reviewed-by: Danilo Krummrich
bytes */
>
> Signed-off-by: Tvrtko Ursulin
> Cc: Christian König
> Cc: Danilo Krummrich
> Cc: Matthew Brost
> Cc: Philipp Stanner
> ---
> include/drm/gpu_scheduler.h | 38 +++--
> 1 file changed, 20 insertions(+), 18 deletions
eader file for internal scheduler API.
* Add helper for peeking too. (Danilo)
* Add (temporary?) drm_sched_cancel_all_jobs() helper to replace amdgpu
amdgpu_job_stop_all_jobs_on_sched().
v3:
* Settle for a copy of __drm_sched_entity_queue_pop in amdgpu for now.
Cc: Christian König
Cc: D
ons of to_drm_sched_job.
>
> Signed-off-by: Tvrtko Ursulin
> Cc: Christian König
> Cc: Danilo Krummrich
> Cc: Matthew Brost
> Cc: Philipp Stanner
> ---
> drivers/gpu/drm/scheduler/sched_entity.c | 11 +++---
> drivers/gpu/drm/scheduler/sched_internal.h | 43 +++
On Thu, Feb 06, 2025 at 02:46:40PM +0100, Christian König wrote:
> Am 06.02.25 um 14:35 schrieb Philipp Stanner:
> > On Wed, 2025-02-05 at 15:33 +, Tvrtko Ursulin wrote:
> > > The helper copies code from the existing
> > > amdgpu_job_stop_all_jobs_on_sched
> > > with the purpose of reducing the
On Wed, Jan 29, 2025 at 04:18:30PM +0100, Philipp Stanner wrote:
> On Tue, 2025-01-28 at 15:56 +0100, Danilo Krummrich wrote:
> > On Tue, Jan 28, 2025 at 03:29:27PM +0100, Philipp Stanner wrote:
> > > diff --git a/drivers/gpu/drm/nouveau/nouveau_sched.c
> > >
On Tue, Jan 28, 2025 at 03:29:27PM +0100, Philipp Stanner wrote:
> drm_sched_init() has a great many parameters and upcoming new
> functionality for the scheduler might add even more. Generally, the
> great number of parameters reduces readability and has already caused
> one missnaming in:
>
> co
On Thu, Jan 23, 2025 at 10:35:43AM +0100, Philipp Stanner wrote:
> On Thu, 2025-01-23 at 10:29 +0100, Danilo Krummrich wrote:
> > On Thu, Jan 23, 2025 at 08:33:01AM +0100, Philipp Stanner wrote:
> > > On Wed, 2025-01-22 at 18:16 +0100, Boris Brezillon wrote:
> > > >
On Thu, Jan 23, 2025 at 08:33:01AM +0100, Philipp Stanner wrote:
> On Wed, 2025-01-22 at 18:16 +0100, Boris Brezillon wrote:
> > On Wed, 22 Jan 2025 15:08:20 +0100
> > Philipp Stanner wrote:
> >
> > > int drm_sched_init(struct drm_gpu_scheduler *sched,
> > > - const struct drm_sched_backend_o
On Wed, Jan 22, 2025 at 03:08:20PM +0100, Philipp Stanner wrote:
> drm_sched_init() has a great many parameters and upcoming new
> functionality for the scheduler might add even more. Generally, the
> great number of parameters reduces readability and has already caused
> one missnaming in:
>
> co
ce this is not documented it can be very fragile so lets
> just remove the internal helper and explicitly check for "nothing
> dequeued", before converting the node to a sched job.
>
> Signed-off-by: Tvrtko Ursulin
> Cc: Christian König
> Cc: Danilo Krummrich
to adding this function if it's *only* used for something that looks
like an abuse of the API by amdgpu. Let's not make that more convenient.
>
> Signed-off-by: Tvrtko Ursulin
> Cc: Christian König
> Cc: Danilo Krummrich
> Cc: Matthew Brost
> Cc: Philipp Stanne
lable video memory, with a default of 32. Adapt this for
the new client interface.
Signed-off-by: Thomas Zimmermann
Acked-by: Danilo Krummrich
Cc: Karol Herbst
Cc: Lyude Paul
Cc: Danilo Krummrich
---
drivers/gpu/drm/nouveau/nouveau_drm.c | 7 +--
1 file changed, 5 insertions(
On 8/12/24 2:34 PM, Thomas Zimmermann wrote:
Hi
Am 12.08.24 um 14:17 schrieb Danilo Krummrich:
On 8/12/24 10:28 AM, Thomas Zimmermann wrote:
Replace the call to drm_fb_helper_output_poll_changed() with a call
to drm_client_dev_hotplug(). It is equivalent in functionality, but
uses the DRM
: Daniel Vetter
Acked-by: Danilo Krummrich
---
drivers/gpu/drm/nouveau/nouveau_vga.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/nouveau/nouveau_vga.c
b/drivers/gpu/drm/nouveau/nouveau_vga.c
index ee637f1fe03d..ab4e11dc0b8a 100644
--- a/drivers/gpu
Vetter
Acked-by: Danilo Krummrich
---
drivers/gpu/drm/nouveau/dispnv50/disp.c | 1 -
drivers/gpu/drm/nouveau/nouveau_display.c | 1 -
2 files changed, 2 deletions(-)
diff --git a/drivers/gpu/drm/nouveau/dispnv50/disp.c
b/drivers/gpu/drm/nouveau/dispnv50/disp.c
index e4c8ce6dd40a
Signed-off-by: Thomas Zimmermann
Acked-by: Danilo Krummrich
---
drivers/gpu/drm/nouveau/nouveau_drm.c | 1 -
drivers/gpu/drm/nouveau/nouveau_vga.c | 7 ---
drivers/gpu/drm/nouveau/nouveau_vga.h | 1 -
3 files changed, 9 deletions(-)
diff --git a/drivers/gpu/drm/nouveau/nouveau_drm.c
b
Hi Easwar,
On 3/29/24 18:00, Easwar Hariharan wrote:
I2C v7, SMBus 3.2, and I3C specifications have replaced "master/slave"
with more appropriate terms. Inspired by and following on to Wolfram's
series to fix drivers/i2c/[1], fix the terminology for users of
I2C_ALGOBIT bitbanging interface, now
comments and a
helper for lock arrays of GEM objects.
Signed-off-by: Christian König
Reviewed-by: Danilo Krummrich
---
Documentation/gpu/drm-mm.rst | 12 ++
drivers/gpu/drm/Kconfig | 6 +
drivers/gpu/drm/Makefile | 2 +
drivers/gpu/drm/drm_exec.c | 278
On 2/28/23 09:33, Christian König wrote:
This adds the infrastructure for an execution context for GEM buffers
which is similar to the existinc TTMs execbuf util and intended to replace
"existing"
it in the long term.
The basic functionality is that we abstracts the necessary loop to lock
ma
Hi Christian,
On 2/28/23 09:33, Christian König wrote:
Hi guys,
thrid round for those patches. They have been in my queue for nearly a
year now because I couldn't find much time to push into this.
Danilo wants to use this for his GPU VAs tracker work and Arun needs it
for hist secure semaphore
21 matches
Mail list logo