Re: convert dc to using krefs for object reference counts

2017-10-03 Thread Harry Wentland
On 2017-10-02 10:38 PM, Dave Airlie wrote: > This series might be a bit of a too big step :-) > Should be okay since ref counts are pretty self-contained. > So in the kernel we use krefs for reference counts for lots of good > reasons, the main one, is no bugs with roll your own atomic reference

Regressions in amd-staging-drm-next

2017-10-03 Thread Martin Babutzka
Hello, Today I tracked down 2 regressions with git bisect: 1. Crash: the most recent amd-drm-staging-next code based kernels result in a complete crash on boot with no interaction possible. The cause is a "tidy up" commit which actually inverts the logical behavior. Went through the amd-gfx list t

Re: [PATCH 4/4] amdgpu/dc: remove bitmap implementation in gpio_service

2017-10-03 Thread Felix Kuehling
On 2017-10-02 11:49 PM, Dave Airlie wrote: > From: Dave Airlie > > This handrolls a bit map implementation (linux/bitmap.h), > but it also actually doesn't need it, the max value greppable > in the code is 31 for a gpio count. So just use a uint32_t for now. > > This should probably migrate to usi

powerplay tidyup/refactor suggestion

2017-10-03 Thread Tom St Denis
Hi all, Soliciting for opinion on a tiny refactor I've noticed is possible in the hwmgr API, we have functions like int (*dynamic_state_management_enable)( struct pp_hwmgr *hw_mgr); int (*dynamic_state_management_disable)(

Re: [PATCH 4/4] amdgpu/dc: remove bitmap implementation in gpio_service

2017-10-03 Thread Harry Wentland
On 2017-10-02 11:49 PM, Dave Airlie wrote: > From: Dave Airlie > > This handrolls a bit map implementation (linux/bitmap.h), > but it also actually doesn't need it, the max value greppable > in the code is 31 for a gpio count. So just use a uint32_t for now. > > This should probably migrate to u

RE: [PATCH xf86-video-ati] Fix VT switching with ShadowFB

2017-10-03 Thread Deucher, Alexander
> -Original Message- > From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf > Of Michel Dänzer > Sent: Tuesday, October 03, 2017 6:55 AM > To: amd-gfx@lists.freedesktop.org > Subject: [PATCH xf86-video-ati] Fix VT switching with ShadowFB > > From: Michel Dänzer > > We w

[PATCH xf86-video-ati] Fix VT switching with ShadowFB

2017-10-03 Thread Michel Dänzer
From: Michel Dänzer We were trying to call acceleration specific functions from LeaveVT. Instead, memset the scanout buffer to all 0 in LeaveVT and allocate a new one in EnterVT. Bugzilla: https://bugs.freedesktop.org/102948 Fixes: 06a465484101 ("Make all active CRTCs scan out an all-black

Re: [PATCH 3/3] amdgpu/dm: don't use after free.

2017-10-03 Thread Harry Wentland
On 2017-10-03 12:27 AM, Dave Airlie wrote: > From: Dave Airlie > > This dereference acrtc after freeing it. > > Found by the kfree cocci script. > > Signed-off-by: Dave Airlie Series is Reviewed-by: Harry Wentland Harry > --- > drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 1 - > 1

Re: [PATCH 4/4] amdgpu/dc: kill a bunch of dead code.

2017-10-03 Thread Harry Wentland
On 2017-10-03 01:11 AM, Dave Airlie wrote: > From: Dave Airlie > > None of this code is used currently. > > Signed-off-by: Dave Airlie Series is Reviewed-by: Harry Wentland Harry > --- > drivers/gpu/drm/amd/display/dc/core/dc.c | 101 > -- > drivers/gpu/drm/am

Re: [PATCH] amdgpu/dc: use kernel ilog2 for log_2.

2017-10-03 Thread Harry Wentland
On 2017-10-02 11:14 PM, Dave Airlie wrote: > From: Dave Airlie > > This should produce the same result. > > Signed-off-by: Dave Airlie Reviewed-by: Harry Wentland Harry > --- > drivers/gpu/drm/amd/display/dc/basics/conversion.c | 10 -- > drivers/gpu/drm/amd/display/dc/basics/conve

Re: [PATCH] amdgpu/dc: don't memset after kzalloc.

2017-10-03 Thread Harry Wentland
On 2017-10-02 10:37 PM, Dave Airlie wrote: > From: Dave Airlie > > We allocate this struct zeroed, so don't need to memset in the > constructor. > > Signed-off-by: Dave Airlie Reviewed-by: Harry Wentland Harry > --- > drivers/gpu/drm/amd/display/dc/core/dc_surface.c | 2 -- > 1 file change

Re: [PATCH] amdgpu/dc: inline dal grph object id functions.

2017-10-03 Thread Harry Wentland
On 2017-10-02 10:36 PM, Dave Airlie wrote: > From: Dave Airlie > > This is worth 400 bytes. > > Signed-off-by: Dave Airlie Reviewed-by: Harry Wentland Harry > --- > .../gpu/drm/amd/display/dc/basics/grph_object_id.c | 61 +- > .../gpu/drm/amd/display/include/grph_object_id.

Re: convert dc to using krefs for object reference counts

2017-10-03 Thread Christian König
Apart from a minor style nit pick which was repeated a few times the series is Reviewed-by: Christian König . Regards, Christian. Am 03.10.2017 um 04:38 schrieb Dave Airlie: This series might be a bit of a too big step :-) So in the kernel we use krefs for reference counts for lots of good re

Re: [PATCH 1/6] amdgpu/dc: convert dc_transfer to use a kref.

2017-10-03 Thread Christian König
Am 03.10.2017 um 04:38 schrieb Dave Airlie: From: Dave Airlie Rolling your own atomic ref counts is frowned upon. Signed-off-by: Dave Airlie --- drivers/gpu/drm/amd/display/dc/core/dc_surface.c | 17 + drivers/gpu/drm/amd/display/dc/dc.h | 2 +- drivers/gpu/d

Re: [PATCH 00/18] use ARRAY_SIZE macro

2017-10-03 Thread Mauro Carvalho Chehab
Em Sun, 1 Oct 2017 20:52:20 -0400 Jérémy Lefaure escreveu: > Anyway, I can tell to each maintainer that they can apply the patches > they're concerned about and next time I may send individual patches. In the case of media, we'll handle it as if they were individual ones. Thanks, Mauro

Re: [Intel-gfx] [PATCH 00/18] use ARRAY_SIZE macro

2017-10-03 Thread Zhi Wang
Thanks for the patch! :) 2017-10-01 22:30 GMT+03:00 Jérémy Lefaure : > Hi everyone, > Using ARRAY_SIZE improves the code readability. I used coccinelle (I > made a change to the array_size.cocci file [1]) to find several places > where ARRAY_SIZE could be used instead of other macros or sizeof >

Re: KFD event handling questions

2017-10-03 Thread Jay Cornwall
On Mon, Oct 2, 2017, at 08:22, Kuehling, Felix wrote: > Is the "new debug trap handler" already working? It seems right now I'm > breaking the "old" debugger backend test. However, given the current > status of that debugger, I guess we can disable those tests for now? > > Can you speak on behalf

Re: [PATCH 00/18] use ARRAY_SIZE macro

2017-10-03 Thread J. Bruce Fields
On Mon, Oct 02, 2017 at 07:35:54AM +0200, Greg KH wrote: > On Sun, Oct 01, 2017 at 08:52:20PM -0400, Jérémy Lefaure wrote: > > On Mon, 2 Oct 2017 09:01:31 +1100 > > "Tobin C. Harding" wrote: > > > > > > In order to reduce the size of the To: and Cc: lines, each patch of the > > > > series is sent

Re: [PATCH 00/18] use ARRAY_SIZE macro

2017-10-03 Thread Jérémy Lefaure
On Mon, 2 Oct 2017 15:22:24 -0400 bfie...@fieldses.org (J. Bruce Fields) wrote: > Mainly I'd just like to know which you're asking for. Do you want me to > apply this, or to ACK it so someone else can? If it's sent as a series > I tend to assume the latter. > > But in this case I'm assuming it'