Re: [PATCH] mempool: micro optimizations
On 3/27/25 20:15, Bruce Richardson wrote: On Wed, Feb 26, 2025 at 03:59:22PM +, Morten Brørup wrote: The comparisons lcore_id < RTE_MAX_LCORE and lcore_id != LCORE_ID_ANY are equivalent, but the latter compiles to fewer bytes of code space. Similarly for lcore_id >= RTE_MAX_LCORE and lcore_id == LCORE_ID_ANY. The rte_mempool_get_ops() function is also used in the fast path, so RTE_VERIFY() was replaced by RTE_ASSERT(). Compilers implicitly consider comparisons of variable == 0 likely, so unlikely() was added to the check for no mempool cache (mp->cache_size == 0) in the rte_mempool_default_cache() function. The rte_mempool_do_generic_put() function for adding objects to a mempool was refactored as follows: - The comparison for the request itself being too big, which is considered unlikely, was moved down and out of the code path where the cache has sufficient room for the added objects, which is considered the most likely code path. - Added __rte_assume() about the cache length, size and threshold, for compiler optimization when "n" is compile time constant. - Added __rte_assume() about "ret" being zero, so other functions using the value returned by this function can be potentially optimized by the compiler; especially when it merges multiple sequential code paths of inlined code depending on the return value being either zero or negative. - The refactored source code (with comments) made the separate comment describing the cache flush/add algorithm superfluous, so it was removed. A few more likely()/unlikely() were added. In general not a big fan of using likely/unlikely, but if they give a perf benefit, we should probably take them. Few more comments inline below. A few comments were improved for readability. Some assertions, RTE_ASSERT(), were added. Most importantly to assert that the return values of the mempool drivers' enqueue and dequeue operations are API compliant, i.e. 0 (for success) or negative (for failure), and never positive. Signed-off-by: Morten Brørup Acked-by: Bruce Richardson Acked-by: Andrew Rybchenko
Re: [External] Re: [PATCH v2] eal/linux: improve ASLR check
On 2025/3/27 16:14, David Marchand wrote: Caution: This is an external email. Please be very careful when clicking links or opening attachments. See http://nok.it/nsb for additional information. Hello, On Thu, Mar 27, 2025 at 9:02 AM Yang Ming wrote: On 2025/3/13 23:37, Stephen Hemminger wrote: On Thu, 13 Mar 2025 14:19:03 +0800 Yang Ming wrote: This change ensures that the current process is checked for being run with 'setarch' before verifying the value of '/proc/sys/kernel/randomize_va_space'. The '-R' or '--addr-no-randomize' parameter of the 'setarch' command is used to disable the randomization of the virtual address space. Fixes: af75078fece3 ("first public release") Cc: sta...@dpdk.org Signed-off-by: Yang Ming Acked-by: Stephen Hemminger Hi Experts, is there any chance to review and accept this patch? I just merged rc0 which means the patch merging fest is opened. I put this patch and a few other EAL patches on my rc1 queue, as those changes don't belong to next-net. Hi David, Got it. Thanks for your update. Looking forward to seeing it in rc1. Brs, Yang Ming
Re: [PATCH v3 2/2] net/vmxnet3: support larger MTU with version 6
Hi Folks, how can you bump them VMXNET3 version, and do we have a VMXNET3 unit test for RSS / Max mtu and 32 queue? On Wed, Nov 6, 2024 at 8:00 AM Ferruh Yigit wrote: > On 11/4/2024 9:44 PM, Jochen Behrens wrote: > > > On 11/4/24 02:52, Morten Brørup wrote: > >> Virtual hardware version 6 supports larger max MTU, but the device > >> information (dev_info) did not reflect this, so it could not be used. > >> > >> Fixes: b1584dd0affe ("net/vmxnet3: support version 6") > >> > >> Signed-off-by: Morten Brørup > > > > Acked-by: Jochen Behrens jochen.behr...@broadcom.com > > > > Applied to dpdk-next-net/main, thanks. >
RE: [PATCH] mempool perf test: test random bulk sizes
> From: Andrew Rybchenko [mailto:andrew.rybche...@oktetlabs.ru] > Sent: Sunday, 30 March 2025 10.29 > > On 2/28/25 19:48, Morten Brørup wrote: > > Bulk requests to get or put objects in a mempool often vary in size. > > A series of tests with pseudo random request sizes, to mitigate the > > benefits of the CPU's dynamic branch predictor, was added. > > > > Also, various other minor changes: > > - Improved the output formatting for readability. > > - Added test for the "default" mempool with cache. > > - Skip the tests for the "default" mempool, if it happens to use the > same > >driver (i.e. operations) as already tested. > > - Replaced bare use of "unsigned" with "unsigned int", > >to make checkpatches happy. > > IMHO, it would be much better and easier to review if all above changes > are done one by one in separate patches. > > > > > Signed-off-by: Morten Brørup > > Overall the idea looks good, so > Acked-by: Andrew Rybchenko > > but I'd be thankful if you split the patch. OK. I'll post a v2 with changes one by one in a series of patches. Let's hope someone else finds the series of simple patches sufficiently readable to care to review. ;-) Thanks, Andrew.