Hi Jie,
With belows to changes,
Acked-by: Huisong Li
在 2024/3/7 11:02, Jie Hai 写道:
This patch adds "filter" and "names" fields to "rte_dev_reg_info"
structure. Names of registers in data fields can be reported and
the registers can be filtered by their names.
The new API rte_eth_dev_get_reg_i
This commit fixes incorrectly set keys in the
QAT testsuite for the RSA algorithm.
Fixes: 9b5465867fb8 ("test/crypto: add RSA none padding cases")
Cc: sta...@dpdk.org
Signed-off-by: Arkadiusz Kusztal
---
app/test/test_cryptodev_asym.c | 74 +-
1 file chan
> This commit fixes incorrectly set keys in the
> QAT testsuite for the RSA algorithm.
>
> Fixes: 9b5465867fb8 ("test/crypto: add RSA none padding cases")
> Cc: sta...@dpdk.org
>
> Signed-off-by: Arkadiusz Kusztal
> ---
> app/test/test_cryptodev_asym.c | 74 +
This commit fixes a segfault, that occurs when NULL pointer
is being set to the aad pointer field.
Fixes: a815a04cea05 ("crypto/qat: support symmetric build op request")
Cc: sta...@dpdk.org
Signed-off-by: Arkadiusz Kusztal
---
drivers/crypto/qat/dev/qat_crypto_pmd_gens.h | 10 ++
1 file
Hello Paul,
On Thu, Mar 7, 2024 at 9:40 PM Paul Szczepanek wrote:
>
> This patchset is proposing adding a new EAL header with utility functions
> that allow compression of arrays of pointers.
>
> When passing caches full of pointers between threads, memory containing
> the pointers is copied mult
在 2024/3/7 11:02, Jie Hai 写道:
This patch adds a telemetry command for registers dump,
and supports get registers with specified names.
The length of the string exported by telemetry is limited
by MAX_OUTPUT_LEN. Therefore, the filter should be more
precise.
An example usage is shown below:
-->
Acked-by: Huisong Li
在 2024/3/7 11:02, Jie Hai 写道:
Since the driver dumps the queue interrupt registers according
to the intr_tqps_num, the counter should be the same.
Fixes: acb3260fac5c ("net/hns3: fix dump register out of range")
Fixes: 936eda25e8da ("net/hns3: support dump register")
Sign
Hi Jie,
A few trivial comments inline,
after changed, you can add
Reviewed-by: Huisong Li
在 2024/3/7 11:02, Jie Hai 写道:
Since the driver is going to support reporting names of
all registers, remove the counter and insert of separators
between different register modules.
Signed-off-by: Jie Ha
On 2024/3/6 18:00, Ferruh Yigit wrote:
On 3/6/2024 9:21 AM, Jie Hai wrote:
This patch adds new device to the driver.
Hi, Ferruh,
Thanks for your reivew.
Just checking if a documentation update is rquired,hns3.rst has
following description, "network engine found in the HiSilicon Kunpeng
920 S
Reviewed-by: Huisong Li
在 2024/3/7 11:02, Jie Hai 写道:
This patch supports reporting names of registers which
can be directly accessed by addresses and filtering
them by names.
Signed-off-by: Jie Hai
---
drivers/net/hns3/hns3_regs.c | 198 +--
1 file changed,
Reviewed-by: Huisong Li
在 2024/3/7 11:02, Jie Hai 写道:
This patch adds names for all registers to be dumped.
For those who can be directly accessed by their addresses,
a new structure containing both name and address is added
and the related arrays is refactored and renamed.
For the remaining m
This commit fixes NULL dereference in the release function,
and three additional coverity issues related to NULL check.
Coverity issue: 415038
Coverity issue: 415050
Coverity issue: 415052
Coverity issue: 415053
Fixes: 477d7d051211 ("common/qat: decouple drivers from common code")
Signed-off-by:
On 2024-03-07 21:27, Stephen Hemminger wrote:
On Thu, 7 Mar 2024 20:50:26 +0100
Mattias Rönnblom wrote:
On 2024-03-05 22:02, Tyler Retzlaff wrote:
On Tue, Mar 05, 2024 at 09:18:20PM +0100, Mattias Rönnblom wrote:
Shouldn't we have a DPDK-native mutex API, rather than using direct
POSIX mutex
On 3/8/2024 3:11 AM, Chaoyong He wrote:
> From: Zerun Fu
>
> The previous logic did not distinguish the firmware type when
> reading the value of "app_cap" during the initialization of the
> PF. This operation is not supported by the flower firmware, and
> this will lead to a startup failure.
> F
在 2024/3/7 11:02, Jie Hai 写道:
This patch adds names for all registers to be dumped.
For those who can be directly accessed by their addresses,
a new structure containing both name and address is added
and the related arrays is refactored and renamed.
For the remaining modules, there may be dif
Hi Ferruh and Thomas,
Kindly ping for review.
在 2024/1/30 14:36, Huisong Li 写道:
This patchset fix some bugs and support attaching and detaching port
in primary and secondary.
---
-v7: fix conflicts
-v6: adjust rte_eth_dev_is_used position based on alphabetical order
in version.map
Maintaining the documentation is part of the job of maintaining a library.
Signed-off-by: David Marchand
---
MAINTAINERS | 9 +
1 file changed, 9 insertions(+)
diff --git a/MAINTAINERS b/MAINTAINERS
index 4755a68274..12e21f78d1 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -428,12 +428,
From: Peng Zhang
When the beat value of all ports are 0, which represent all
ports are unused. But the current port starts beat before
the check process, so it needs to sleep 1 second waiting
the beat value change and to ignore the current port.
Fixes: 8b9a83ea2af2 ("net/nfp: enlarge range of sk
On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
> From: Shai Brandes
>
> This patch makes several changes to improve
> the style and readability of the code.
>
> Signed-off-by: Shai Brandes
> Reviewed-by: Amit Bernstein
> ---
> drivers/net/ena/hal/ena_com.c | 13 +
> 1 file chang
On 2024/3/1 19:10, Ferruh Yigit wrote:
On 3/1/2024 6:55 AM, huangdengdui wrote:
On 2024/2/29 17:25, Ferruh Yigit wrote:
On 2/29/2024 3:58 AM, huangdengdui wrote:
On 2024/2/28 21:07, Ferruh Yigit wrote:
On 2/28/2024 2:27 AM, huangdengdui wrote:
On 2024/2/27 0:43, Ferruh Yigit wrote:
On
When DPDK is used as a subproject, include the required compile
arguments so that the parent project is also built with the appropriate
cflags (most importantly -march). Use the same cflags as pkg-config.
Fixes: f93a605f2d6e ("build: add definitions for use as Meson subproject")
Cc: sta...@dpdk.or
Thanks Ferruh, we will fix and upload a new patchset
בתאריך 8 במרץ 2024 13:18, Ferruh Yigit כתב:
CAUTION: This email originated from outside of the organization. Do not click
links or open attachments unless you can confirm the sender and know the
content is safe.
On 3/6/2024 12:24 PM, shai
Recheck-request: iol-unit-arm64-testing
> Subject: [PATCH 21/21] test/security: add out of place sgl test case for TLS
> 1.2
>
> Add TLS 1.2 out-of-place multi-segmented packet test.
>
> Signed-off-by: Aakash Sasidharan
<>
On 2/16/2024 9:06 AM, Stephen Hemminger wrote:
Testpmd is misusing EAL logtype for some errors.
Since the code directly has a macro for logging, use that.
Signed-off-by: Stephen Hemminger
Acked-by: Huisong Li
fix testpmd
---
app/test-pmd/testpmd.c | 42 +++-
On Fri, Mar 8, 2024 at 12:59 PM Robin Jarry wrote:
>
> When DPDK is used as a subproject, include the required compile
> arguments so that the parent project is also built with the appropriate
> cflags (most importantly -march). Use the same cflags as pkg-config.
>
> Fixes: f93a605f2d6e ("build: a
This is a cleanup I had in store for ages but never sent.
The idea is to reuse the conventions from EAL and examples when it
comes to using getopt API.
--
David Marchand
David Marchand (4):
app/testpmd: fix stats-period option check
app/testpmd: fix burst option parsing
app/testpmd: check
Rather than silently ignore an invalid value, raise an error for
stats-period user input.
Fixes: cfea1f3048d1 ("app/testpmd: print statistics periodically")
Cc: sta...@dpdk.org
Signed-off-by: David Marchand
---
app/test-pmd/parameters.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
dif
rte_eth_dev_info_get() is not supposed to fail for a valid port_id, but
for the theoretical case when it would fail, raise an error rather than
skip subsequent options.
Fixes: 6f51deb903b2 ("app/testpmd: check status of getting ethdev info")
Cc: sta...@dpdk.org
Signed-off-by: David Marchand
---
Checking the number of rxq/txq in the middle of option parsing is
confusing. Move the check where nb_rxq / nb_txq are modified.
Signed-off-by: David Marchand
---
app/test-pmd/parameters.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/app/test-pmd/parameters.c b/app/
This is a cleanup similar to previous ones in EAL and examples.
Instead of using strcmp for every long options while getopt_long already
did such parsing, rely on getopt_long return value.
Note for reviewers: this patch is best reviewed once applied locally and
displayed with git show -w.
Signed-
On 3/8/2024 1:19 PM, Brandes, Shai wrote:
> Thanks Ferruh, we will fix and upload a new patchset
>
Hi Shai,
If this is the only issue I can update while merging, so please wait
before sending a new version.
> בתאריך 8 במרץ 2024 13:18, Ferruh Yigit כתב:
> CAUTION: This email originated from ou
> -Original Message-
> From: Wathsala Wathawana Vithanage
> Sent: Thursday, March 7, 2024 4:21 PM
> To: Power, Ciara ; Patrick Robb
> Cc: Akhil Goyal ; Dooley, Brian ;
> Ji, Kai ; De Lara Guarch, Pablo
> ; Aaron Conole ;
> dev@dpdk.org; Sivaramakrishnan, VenkatX
> ; tho...@monjalon.net;
Hi all,
I would like to start a discussion about legacy flow actions for packet
modification.
As of DPDK 21.11 many packet modification flow actions were deprecated in favor
of generic
RTE_FLOW_ACTION_TYPE_MODIFY_FIELD action (see [1]).
I compiled a review of the current state of all deprecated
On Fri, 8 Mar 2024 19:05:32 +0530
"Singh, Aman Deep" wrote:
> > if (ret) {
> > - RTE_LOG(ERR, EAL, "can not get port by device %s!\n",
> > - device_name);
> > + fprintf(stderr, "Can not get port by device %s!\n",
> > devic
Add an opt-out list for get maintainer tool. This is helpful
to avoid getting bounce messages and to allow developers
who do not want direct mail.
Signed-off-by: Stephen Hemminger
---
.get_maintainer.ignore | 11 +++
1 file changed, 11 insertions(+)
create mode 100644 .get_maintainer.i
On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
> From: Shai Brandes
>
> ENA device will send asynchronous notifications to the
> driver in order to notify users about sub-optimal configurations
> and refer them to public AWS documentation for further action.
>
Hi Shai,
This is an interesting
On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
> From: Shai Brandes
>
> In case the application enables fast mbuf release optimization,
> the driver releases 256 TX mbufs in bulk upon reaching the
> TX free threshold.
> The existing implementation utilizes rte_mempool_put_bulk for bulk
> freein
On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
> From: Shai Brandes
>
> Changed the base HAL folder to hal.
>
Hi Shai,
What is the motivation behind this change?
This not a functional change and technically you can rename the folder
to whatever you want, but in dpdk drivers common name is '
On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
> From: Shai Brandes
>
> The driver will set the size of the LLQ header size according to the
> recommendation from the device.
> Replaced `enable_llq` and `large_llq_hdr` devargs with
> a new devarg `llq_policy` that accepts the following values:
On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
> From: Shai Brandes
>
> limits the exponent in the exponential backoff
> mechanism in order to avoid the value overflowing.
>
Is this a fix?
What was the impact of the overflowing if not limited? And is there a
significance of the value 16, can
On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
> From: Shai Brandes
>
> Add a new driver supported feature bit for TX IPv6 checksum offload.
>
"net/ena/base: support IPv6 checksum offload" ?
On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
> From: Shai Brandes
>
> ENA_MEMCPY_TO_DEVICE_64 macro needs pci bus id in order
> to write to the device memory when using llq.
>
As far as I can see macro doesn't use 'bus' at all, "(void)(bus);",
how/why it is needed for LLQ? Can you please de
On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
> From: Shai Brandes
>
> Hi all, the ena v2.9.0 release introduces:
> 1. HAL upgrade:
>- renamed the 'base' folder to be 'hal'
>- separated the HAL patches instead of a bulk update.
> 2. Restructured ena stats and metrics.
> 3. Restructured
On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
> From: Shai Brandes
>
> 1. modify log prints to use correct format specifier
>for unsigned variables.
>
I am not user using correct format specifier is cosmetic change, perhaps
we don't understand same thing, can you please define "cosmetic c
On 3/8/2024 5:43 PM, Ferruh Yigit wrote:
> On 3/6/2024 12:24 PM, shaib...@amazon.com wrote:
>> From: Shai Brandes
>>
>> 1. modify log prints to use correct format specifier
>>for unsigned variables.
>>
>
> I am not user using correct format specifier is cosmetic change, perhaps
> we don't und
On 3/8/2024 5:07 PM, Stephen Hemminger wrote:
> Add an opt-out list for get maintainer tool. This is helpful
> to avoid getting bounce messages and to allow developers
> who do not want direct mail.
>
> Signed-off-by: Stephen Hemminger
> ---
> .get_maintainer.ignore | 11 +++
> 1 file c
On Fri, 8 Mar 2024 17:45:56 +
Ferruh Yigit wrote:
> On 3/8/2024 5:07 PM, Stephen Hemminger wrote:
> > Add an opt-out list for get maintainer tool. This is helpful
> > to avoid getting bounce messages and to allow developers
> > who do not want direct mail.
> >
> > Signed-off-by: Stephen Hem
The previous code allowed the number of Tx queues to be set higher than
the number of Rx queues. If a packet was sent on a Tx queue with index
>= number Rx queues there was a segfault.
This commit fixes the issue by creating an Rx queue for every Tx queue
meaning that an event buffer is allocated
On Fri, Mar 08, 2024 at 05:45:56PM +, Ferruh Yigit wrote:
> On 3/8/2024 5:07 PM, Stephen Hemminger wrote:
> > Add an opt-out list for get maintainer tool. This is helpful
> > to avoid getting bounce messages and to allow developers
> > who do not want direct mail.
> >
> > Signed-off-by: Steph
There are some places EAL logtype is being used in testpmd
and examples where it should not be. Lets reserve EAL
logtype to only be used by DPDK internals.
Stephen Hemminger (3):
examples/l2fwd-keepalive: don't use EAL logtype
examples/vm_power_manager: do not use EAL logtype
testpmd: replac
EAL logtype should be reserved for EAL library.
This example is already has a log wrapper so use it.
Signed-off-by: Stephen Hemminger
Acked-by: Huisong Li
Acked-by: Morten Brørup
---
examples/l2fwd-keepalive/main.c | 2 --
examples/l2fwd-keepalive/shm.c | 29 -
ex
Be consistent for all the error printouts and use fprintf().
The EAL logtype is reserved for internal use by EAL.
Signed-off-by: Stephen Hemminger
Acked-by: David Hunt
Acked-by: Huisong Li
---
examples/vm_power_manager/main.c | 11 ---
1 file changed, 4 insertions(+), 7 deletions(-)
d
Testpmd is misusing EAL logtype for some errors.
Since the code directly has a macro for logging, use that.
Also, replace fprintf(stderr, ...) with TESTPMD_LOG where
appropriate.
Signed-off-by: Stephen Hemminger
Acked-by: Huisong Li
fix testpmd
---
app/test-pmd/testpmd.c | 221 +++
Add an opt-out list for get maintainer tool. This is helpful
to avoid getting bounce messages and to allow developers
who do not want direct mail.
Signed-off-by: Stephen Hemminger
---
v2 - drop users already with new email in mailmap
.get_maintainer.ignore | 11 +++
1 file changed, 11
> -Original Message-
> From: Stephen Hemminger
> Sent: Friday, March 1, 2024 18:15
> To: dev@dpdk.org
> Cc: Stephen Hemminger ; Dariusz Sosnowski
> ; Slava Ovsiienko ; Ori
> Kam ; Suanming Mou ; Matan
> Azrad
> Subject: [PATCH v2 14/71] net/mlx5: replace use of fixed size rte_memcpy
>
>
> Subject: RE: [PATCH] net/netvsc: fix number Tx queues > Rx queues
>
> > Subject: Re: [PATCH] net/netvsc: fix number Tx queues > Rx queues
> >
> > On Thu, 29 Feb 2024 19:29:11 +
> > Alan Elder wrote:
> >
> > > The previous code allowed the number of Tx queues to be set higher
> > > than th
The current limit of file descriptors is too low, it should have
been set to the maximum possible to send across an unix domain
socket.
This is an attempt to allow increasing it without breaking ABI.
But in the process it exposes what is broken about how symbol
versions are checked in check-symbol
Modify the user information with total average latency per worker
in both CSV and console logs.
Signed-off-by: Vipin Varghese
V3 Changes:
- update CSV_TOTAL_LINE_FMT to change Avg Cycles / op per worker
V2 Changes:
- keep one-digit precision is enough, suggested by Chengwen
---
app/test-dma-
"Power, Ciara" writes:
> Hi Aaron,
>
>> -Original Message-
>> From: Aaron Conole
>> Sent: Wednesday, March 6, 2024 2:57 PM
>> To: Power, Ciara
>> Cc: Sivaramakrishnan, VenkatX ; Akhil
>> Goyal ; Ji, Kai ; pr...@iol.unh.edu;
>> dev@dpdk.org; De Lara Guarch, Pablo ;
>> Thomas Monjalon ; D
Sure, will upload a new seried, thanks!
בתאריך 8 במרץ 2024 19:36, Ferruh Yigit כתב:
CAUTION: This email originated from outside of the organization. Do not click
links or open attachments unless you can confirm the sender and know the
content is safe.
On 3/6/2024 12:24 PM, shaib...@amazon.c
On 3/6/2024 9:20 AM, Jie Hai wrote:
> Currently, hns3 driver only enable user priority 0-3 when the
> user set TC number to 4 and enable PFC and ETS by dev_configure.
> In this moment, the packet with user priority 4-7 cannot trigger
> PFC frame. By the way, the nb_tcs from user can never be 0 beca
Both XDP and TAP device are limited in the number of queues
because of limitations on the number of file descriptors that
are allowed. The original choice of 8 was too low; the allowed
maximum is 253 according to unix(7) man page.
This may look like a serious ABI breakage but it is not.
It is simp
rte_thash_gfni_bulk and rte_thash_gfni_bulk_stub both return void.
Remove superfluous return statement from rte_thash_gfni_bulk.
Fixes: 944a03a5cfc1 ("hash: fix MSVC link on GFNI stubs")
Cc: step...@networkplumber.org
Signed-off-by: Tyler Retzlaff
---
lib/hash/rte_thash_gfni.h | 2 +-
1 file ch
There are some places EAL logtype is being used in testpmd
and examples where it should not be. Lets reserve EAL
logtype to only be used by DPDK internals.
Stephen Hemminger (3):
examples/l2fwd-keepalive: don't use EAL logtype
examples/vm_power_manager: do not use EAL logtype
testpmd: repl
EAL logtype should be reserved for EAL library.
This example is already has a log wrapper so use it.
Signed-off-by: Stephen Hemminger
Acked-by: Huisong Li
Acked-by: Morten Brørup
---
examples/l2fwd-keepalive/main.c | 2 --
examples/l2fwd-keepalive/shm.c | 29 -
ex
Be consistent for all the error printouts and use fprintf().
The EAL logtype is reserved for internal use by EAL.
Signed-off-by: Stephen Hemminger
Acked-by: David Hunt
Acked-by: Huisong Li
---
examples/vm_power_manager/main.c | 11 ---
1 file changed, 4 insertions(+), 7 deletions(-)
d
Testpmd is misusing EAL logtype for some errors.
Since the code directly has a macro for logging, use that.
Also, replace fprintf(stderr, ...) with TESTPMD_LOG where
appropriate.
Signed-off-by: Stephen Hemminger
Acked-by: Huisong Li
fix testpmd
---
app/test-pmd/testpmd.c | 221 +++
67 matches
Mail list logo