> -Original Message-
> From: Ferruh Yigit
> Sent: Tuesday, January 11, 2022 6:16 PM
> To: Rakesh Kudurumalla ; Nithin Kumar
> Dabilpuram ; Kiran Kumar Kokkilagadda
> ; Sunil Kumar Kori ; Satha
> Koteswara Rao Kottidi
> Cc: dev@dpdk.org
> Subject: [EXT] Re: [PATCH 1/2] net/cnxk: update m
Hi,
> -Original Message-
> From: Dmitry Kozlyuk
> Sent: Tuesday, December 28, 2021 11:21 AM
> To: dev@dpdk.org
> Cc: Slava Ovsiienko ; sta...@dpdk.org; Matan
> Azrad
> Subject: [PATCH] net/mlx5: relax headroom assertion
>
> A debug assertion in Single-Packet Receive Queue (SPRQ) mode re
After "port rxq|txq stop"
the stopped queue was used in forwarding nonetheless,
which may cause undefined behavior in the PMD.
Record the configured queue state
and account for it when launching forwarding as follows:
++-+-+---+
|RxQ |TxQ |Con
On Thu, Jan 13, 2022 at 11:06 AM Dharmik Thakkar
wrote:
>
> Current mempool per core cache implementation stores pointers to mbufs
> On 64b architectures, each pointer consumes 8B
> This patch replaces it with index-based implementation,
> where in each buffer is addressed by (pool base address +
From: Jerin Jacob
Based on device support and use-case need, there are two different ways
to enable PFC. The first case is the port level PFC configuration, in
this case, rte_eth_dev_priority_flow_ctrl_set() API shall be used to
configure the PFC, and PFC frames will be generated using based on V
From: Sunil Kumar Kori
Patch adds command line options to configure queue based
priority flow control.
- Syntax command is given as below:
set pfc_queue_ctrl rx\
tx
- Example command to configure queue based priority flow control
on rx and tx side for port 0, Rx queue 0, Tx
Thank you for the comments. I agree that OpenSSL PMD needs a major refactoring
in asym crypto.
I have asked Akhil to reject this patch series.
-Original Message-
From: Kusztal, ArkadiuszX
Sent: Tuesday, December 28, 2021 2:41 PM
To: Ramkumar Balu ; Akhil Goyal ; Anoob
Joseph ; Doherty
Hi Dharmik,
> >
> >> Current mempool per core cache implementation stores pointers to mbufs
> >> On 64b architectures, each pointer consumes 8B
> >> This patch replaces it with index-based implementation,
> >> where in each buffer is addressed by (pool base address + index)
> >> It reduces the a
Hi Ganapati,
> -Original Message-
> From: Kundapura, Ganapati
> Sent: Tuesday, January 11, 2022 4:07 PM
> To: jerinjac...@gmail.com; Jayatheerthan, Jay ;
> dev@dpdk.org
> Cc: Gujjar, Abhinandan S
> Subject: [PATCH v3 1/2] eventdev/crypto_adapter: move crypto ops to circular
> buffer
>
01/11/2021 14:35, Ferruh Yigit:
> Linux kernel 'get_maintainer.pl' script supports running out of Linux
> tree since commit
> 31bb82c9caa9 ("get_maintainer: allow usage outside of kernel tree")
>
> As commit is a few years old now, integrating it to DPDK and removing
> ugly workaround for it.
>
>
Hi,
The explanation should be in the patch, not the cover letter.
Actually, you don't need a cover letter for a single patch.
Copying it here:
"
dpdk is fairly expensive to build in GitHub.
It's helpful to abandon old builds as soon as there's a new
build waiting instead of wasting resources on t
An errata exists whereby NIX may incorrectly overwrite the value in
NIX_SQ_CTX_S[SQ_INT]. This may cause set interrupts to get cleared or
causing an QINT when no error is outstanding.
As a workaround, software should always read all SQ debug registers
and not just rely on NIX_SQINT_E bits set in NI
Patch updates configured meter bpf is in recevie queue
context during meter creation
Signed-off-by: Rakesh Kudurumalla
Acked-by: Sunil Kumar Kori
---
v2: Fix commit message
drivers/net/cnxk/cn10k_rte_flow.c | 7 +++
drivers/net/cnxk/cnxk_ethdev_mtr.c | 21 -
2 files ch
Patch updates meter algorithm in nix band profile
structure
Signed-off-by: Rakesh Kudurumalla
Acked-by: Sunil Kumar Kori
---
v2: series patch of 1/2
drivers/common/cnxk/hw/nix.h | 5 ---
drivers/common/cnxk/roc_nix_bpf.c | 61 +--
2 files changed, 17 insertions
Patch updates configured meter bpf is in receive queue
context during meter creation
Signed-off-by: Rakesh Kudurumalla
Acked-by: Sunil Kumar Kori
---
v3: Fix commit message spelling
drivers/net/cnxk/cn10k_rte_flow.c | 7 +++
drivers/net/cnxk/cnxk_ethdev_mtr.c | 21 -
2
Patch updates meter algorithm in nix band profile
structure
Signed-off-by: Rakesh Kudurumalla
Acked-by: Sunil Kumar Kori
---
v3: series patch of 1/2
drivers/common/cnxk/hw/nix.h | 5 ---
drivers/common/cnxk/roc_nix_bpf.c | 61 +--
2 files changed, 17 insertions
On Thu, Jan 13, 2022, 6:42 AM Thomas Monjalon wrote:
> Hi,
>
> The explanation should be in the patch, not the cover letter.
> Actually, you don't need a cover letter for a single patch.
> Copying it here:
> "
> dpdk is fairly expensive to build in GitHub.
>
> It's helpful to abandon old builds a
Hi Konstantin,
> > > Hardware IP reassembly may be incomplete for multiple reasons like
> > > reassembly timeout reached, duplicate fragments, etc.
> > > To save application cycles to process these packets again, a new
> > > mbuf ol_flag (RTE_MBUF_F_RX_IPREASSEMBLY_INCOMPLETE) is added to
> > > sho
Hi Konstantin,
> > > > > > Another question - if we have reassembly_conf_set() would it make
> sense
> > to
> > > > > > have also reassembly_conf_get?
> > > > > > So user can retrieve current ip_reassembly config values?
> > > > > >
> > > > > The set/supported values can be retrieved using rte_eth
Hi,
Thanks.
> -Original Message-
> From: Maxime Gouin
> Sent: Wednesday, January 05, 2022 18:27
> To: dev@dpdk.org
> Cc: Maxime Gouin ; Xu, Rosen
> ; Zhang, Qi Z ; Zhang, Tianfei
> ; Olivier Matz
> Subject: [PATCH] bus/ifpga: remove useless check while browsing devices
>
> reported by
The maximum packet headers size for TSO is calculated as a sum of
Ethernet, VLAN, IPv6 and TCP headers (plus inner headers).
The rationale behind choosing IPv6 and TCP is their headers
are bigger than IPv4 and UDP respectively, giving us the maximum
possible headers size. But it is not true for L3
Hi Akhil,
> Hi Konstantin,
> > > > Hardware IP reassembly may be incomplete for multiple reasons like
> > > > reassembly timeout reached, duplicate fragments, etc.
> > > > To save application cycles to process these packets again, a new
> > > > mbuf ol_flag (RTE_MBUF_F_RX_IPREASSEMBLY_INCOMPLETE)
Preparation of the stride size and the number of strides for
Multi-Packet RQ was updated recently to accommodate the hardware
limitation about minimum WQE size. The wrong assertion was
introduced to ensure this limitation is met. Assert that the
configured WQE size is not less than the minimum supp
> > > > > > > Another question - if we have reassembly_conf_set() would it make
> > sense
> > > to
> > > > > > > have also reassembly_conf_get?
> > > > > > > So user can retrieve current ip_reassembly config values?
> > > > > > >
> > > > > > The set/supported values can be retrieved using rte_et
> Hi Akhil,
>
> > Hi Konstantin,
> > > > > Hardware IP reassembly may be incomplete for multiple reasons like
> > > > > reassembly timeout reached, duplicate fragments, etc.
> > > > > To save application cycles to process these packets again, a new
> > > > > mbuf ol_flag (RTE_MBUF_F_RX_IPREASSEMBL
On Thu, Jan 13, 2022 at 12:52:04AM +0900, Yasuhiro Ohara wrote:
>
> Hi,
>
> My system developper friend recently ran into a problem where
> l3fwd does not appear to receive balanced traffic on Intel XL710,
> but it is resolved when the attached patch is applied.
>
> -.rss_hf = ETH_RS
During a large refactoring sweep for 21.11, a previous commit
removed the dependency the bnxt driver had on Linux virtual
bus drivers, such as vfio-pci. This breaks port detection.
This patch adds the kmod dependency back as it was.
Fixes: 295968d17407 ("ethdev: add namespace")
Signed-off-by: Geo
17/12/2021 09:54, Ruifeng Wang:
> As per design document, RTE_ARCH is the name of the architecture.
> However, the definition was missing on Arm with meson build.
> It impacts applications that refers to this string.
>
> Added for Arm builds.
>
> Fixes: b1d48c41189a ("build: support ARM with meso
A common request on-list has been to allow more of the DPDK build to be
disabled by those who are
doing their own builds and only use a subset of the libraries. To this end,
this patchset makes some
infrastructure changes [first two patches] to make it easier to have libraries
disabled, and then
Align the code in lib/meson.build with that in drivers/meson.build to
enable recursive disabling of libraries, i.e. if library b depends on
library a, disable library b if a is disabled (either explicitly or
implicitly). This allows libraries to be optional even if other DPDK
libs depend on them, s
Rather than maintaining a list of the libraries the unit tests need, and
having to conditionally include/omit optional libs from the list, we can
just link against all available libraries, simplifying the code
considerably.
Signed-off-by: Bruce Richardson
---
app/test/meson.build | 47 +-
Allow the 'node' library to be disabled in builds
Signed-off-by: Bruce Richardson
---
lib/meson.build | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/meson.build b/lib/meson.build
index af4662e942..dd20fe70a6 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -74,6 +74,7 @@ optional_l
Add the flow_classify library to the list of optional libraries, and
ensure tests can build with it disabled.
Signed-off-by: Bruce Richardson
---
app/test/meson.build | 7 +--
lib/meson.build | 1 +
2 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/app/test/meson.build b/ap
Add port, table and pipeline libraries - collectively often known as
the "packet framework" - to the list of optional libraries, and
ensure tests can build with them disabled.
Signed-off-by: Bruce Richardson
---
app/test/meson.build | 20 +---
lib/meson.build | 3 +++
2 fi
Allow disabling of the cfgfile library in builds.
Signed-off-by: Bruce Richardson
---
lib/meson.build | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/meson.build b/lib/meson.build
index dcc1b4d835..8e5acd7819 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -67,6 +67,7 @@ libraries
On Thu, 13 Jan 2022 17:39:12 +
Bruce Richardson wrote:
> A common request on-list has been to allow more of the DPDK build to be
> disabled by those who are
> doing their own builds and only use a subset of the libraries. To this end,
> this patchset makes some
> infrastructure changes [fir
> > > > >
> > > > > +/**
> > > > > + * In case of IP reassembly offload failure, ol_flags in mbuf will
> > > > > be set
> > > > > + * with RTE_MBUF_F_RX_IPREASSEMBLY_INCOMPLETE and packets will
> > be
> > > > returned
> > > > > + * without alteration. The application can retrieve the attached
That makes sense. Thank you.
It would be great to have further comments from the maintener.
For the RTE framework integrity, would it be better for us
to have a consistent meaning for the ETH_RSS_XXX flags?
Do the other drivers act differently?
Best regards,
Yasu
From: Bruce Richardson
Subjec
> -Original Message-
> From: Richardson, Bruce
> Sent: Thursday, January 13, 2022 11:06 PM
> To: Yasuhiro Ohara
> Cc: dev@dpdk.org; Xing, Beilei
> Subject: Re: ETH_RSS_IP only does not seem to balance traffic
>
> On Thu, Jan 13, 2022 at 12:52:04AM +0900, Yasuhiro Ohara wrote:
> >
> >
Thank you for the confirmation!
Best regards,
Yasu
From: "Xing, Beilei"
Subject: RE: ETH_RSS_IP only does not seem to balance traffic
Date: Fri, 14 Jan 2022 01:44:45 +
Message-ID:
>
>
>> -Original Message-
>> From: Richardson, Bruce
>> Sent: Thursday, January 13, 2022 11:06 P
While utilizing dumpcap with our app, we have observed the captured file
producing out of order timestamps to include negative times. We are still
investigating the root cause but believe it is in lib/pcapng. While doing
some testing of this issue, this behavior was not observed with pcap. In
th
Here are a couple patches to the enic PMD that should apply on top of
the patch:
'net/enic: support GENEVE flow item' by Hyong Youb Kim.
John Daley (3):
net/enic: add support for eCPRI matching
net/enic: update VIC firmware API
net/enic: support max descriptors allowed by adapter
d
eCPRI message can be over Ethernet layer (.1Q supported also) or over
UDP layer. Message header formats are the same in these two variants.
Only up though the first packet header in the PDU can be matched.
RSS on the eCPRI header fields is not supported.
Signed-off-by: John Daley
Reviewed-by: Hy
Update the configuration structure used between the adapter and
driver. The structure is compatible with all Cisco VIC adapters.
Signed-off-by: John Daley
Reviewed-by: Hyong Youb Kim
---
drivers/net/enic/base/vnic_enet.h | 22 ++
1 file changed, 22 insertions(+)
diff --git
Newer VIC adapters have the max number of supported RX and TX
descriptors in their configuration. Use these values as the
maximums.
Signed-off-by: John Daley
Reviewed-by: Hyong Youb Kim
---
drivers/net/enic/base/cq_enet_desc.h | 6 -
drivers/net/enic/enic_res.c | 20 +-
Hi Jiayu,
This is first round of review, I'll spend time on OVS patches later and look
back.
> -Original Message-
> From: Hu, Jiayu
> Sent: Friday, December 31, 2021 5:55 AM
> To: dev@dpdk.org
> Cc: maxime.coque...@redhat.com; i.maxim...@ovn.org; Xia, Chenbo
> ; Richardson, Bruce ; Van
> -Original Message-
> From: Yigit, Ferruh
> Sent: Wednesday, January 12, 2022 10:36 PM
> To: Thomas Monjalon ; Andrew Rybchenko
> ; Hemant Agrawal ;
> Tyler Retzlaff ; Xia, Chenbo
> ; Jerin Jacob
> Cc: dev@dpdk.org; Yigit, Ferruh ; Stephen Hemminger
>
> Subject: [PATCH v3] ethdev: mark
Hi Abhimanyu,
> -Original Message-
> From: abhimanyu.sa...@xilinx.com
> Sent: Tuesday, January 11, 2022 1:33 PM
> To: dev@dpdk.org
> Cc: Xia, Chenbo ; maxime.coque...@redhat.com;
> andrew.rybche...@oktetlabs.ru; Abhimanyu Saini
> Subject: [PATCH] vdpa/sfc: make MCDI memzone name unique
>
Hi Yunjuan,
> -Original Message-
> From: Yunjian Wang
> Sent: Saturday, January 8, 2022 4:14 PM
> To: dev@dpdk.org
> Cc: maxime.coque...@redhat.com; Xia, Chenbo ;
> dingxiaoxi...@huawei.com; xudin...@huawei.com; Yunjian Wang
> ; sta...@dpdk.org
> Subject: [dpdk-dev] [PATCH] net/virtio: fi
> -Original Message-
> From: Pei, Andy
> Sent: Monday, December 13, 2021 3:01 PM
> To: dev@dpdk.org
> Cc: Xia, Chenbo ; sta...@dpdk.org
> Subject: [PATCH v3] vdpa/ifc: fix log info mismatch
>
> Fix log info mismatch.
>
> Fixes: a3f8150eac6d ("net/ifcvf: add ifcvf vDPA driver")
> Cc: sta.
Fix log info mismatch.
Fixes: a3f8150eac6d ("net/ifcvf: add ifcvf vDPA driver")
Cc: sta...@dpdk.org
Signed-off-by: Andy Pei
---
drivers/vdpa/ifc/base/ifcvf.c | 14 --
1 file changed, 8 insertions(+), 6 deletions(-)
diff --git a/drivers/vdpa/ifc/base/ifcvf.c b/drivers/vdpa/ifc/base/
Usually the last avail index and last used index is 0, but for target
device of live migration, the last avail index and last used index is
not 0. So I think some log is helpful.
Signed-off-by: Andy Pei
---
lib/vhost/vhost_user.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/lib/vhost
From: Xuan Ding
When choosing IOVA as PA mode, IOVA is likely to be discontinuous,
which requires page by page mapping for DMA devices. To be consistent,
this patch implements page by page mapping instead of mapping at the
region granularity for both IOVA as VA and PA mode.
Fixes: 7c61fa08b716 (
From: Xuan Ding
This patchset fixes the issue of incorrect DMA mapping in PA mode.
Due to the ambiguity of host_phys_addr naming in the guest page
struct, rename it to host_iova.
Xuan Ding (2):
vhost: fix physical address mapping
vhost: rename field in guest page struct
lib/vhost/vhost.h
From: Xuan Ding
This patch renames the host_phys_addr to host_iova in guest_page
struct. The host_phys_addr is iova, it depends on the DPDK
IOVA mode.
Signed-off-by: Xuan Ding
---
lib/vhost/vhost.h | 10 +-
lib/vhost/vhost_user.c | 24
lib/vhost/virtio_net
> -Original Message-
> From: Pei, Andy
> Sent: Friday, January 14, 2022 3:19 PM
> To: dev@dpdk.org
> Cc: Xia, Chenbo
> Subject: [PATCH] vhost: add some log for vhost message
> VHOST_USER_SET_VRING_BASE
I suggest the title be:
vhost: add log for VHOST_USER_SET_VRING_BASE
>
> Usually th
> -Original Message-
> From: Harold Huang
> Sent: Thursday, December 23, 2021 12:43 PM
> To: dev@dpdk.org
> Cc: Maxime Coquelin ; Xia, Chenbo
>
> Subject: [PATCH] net/virtio: fix unreleased resource when creating virtio user
> dev is failed
>
> When eth_virtio_dev_init is failed, the reg
Hi Chenbo,
Thanks for you reply.
I will send a V2 patch to address it.
-Original Message-
From: Xia, Chenbo
Sent: Friday, January 14, 2022 3:40 PM
To: Pei, Andy ; dev@dpdk.org
Subject: RE: [PATCH] vhost: add some log for vhost message
VHOST_USER_SET_VRING_BASE
> -Original Message-
58 matches
Mail list logo