On Nov 3, 2006, at 12:08 AM, William Stein wrote:
> Actually, I'm going to do this: > > SageObject > | > | > \|/ > Parent > | > | > \|/ > ParentWithGens > > Since the "Object" in ParentObject is redundant, and this is more > consistent > with "Element" instead of "ElementObject". Also, Gens instead of > Generators, > since it is pretty clear what is meant. My only objection to this (a minor one) is that "Parent" is a function name in MAGMA and you always talk about not being confusing to people from MAGMA-land. It definitely is my preferred name. David --~--~---------~--~----~------------~-------~--~----~ To post to this group, send email to sage-devel@googlegroups.com To unsubscribe from this group, send email to [EMAIL PROTECTED] For more options, visit this group at http://groups.google.com/group/sage-devel URLs: http://sage.scipy.org/sage/ and http://modular.math.washington.edu/sage/ -~----------~----~----~----~------~----~------~--~---