On 8/22/23 04:01, Philippe Mathieu-Daudé wrote:
Commit 46be8425ff ("tcg: Implement tcg_gen_{h,w}swap_{i32,i64}")
introduced the generic hswap_i32(). Use it instead of open-coding
it as gen_swap_half().

Signed-off-by: Philippe Mathieu-Daudé<phi...@linaro.org>
---
  target/arm/tcg/translate-a32.h  | 6 ------
  target/arm/tcg/translate-neon.c | 4 ++--
  target/arm/tcg/translate.c      | 4 ++--
  3 files changed, 4 insertions(+), 10 deletions(-)

Reviewed-by: Richard Henderson <richard.hender...@linaro.org>


r~

Reply via email to