On 18 January 2012 15:50, Mark Langsdorf <mark.langsd...@calxeda.com> wrote: > Create two functions, write_secondary_boot() and secondary_cpu_reset_hook(), > to allow platforms more control of how secondary CPUs are brought up. The > new functions default to NULL and aren't called unless they are populated > so there are no changes to existing platform models. > > Signed-off-by: Mark Langsdorf <mark.langsd...@calxeda.com> > --- > I'll add this to the Highbank patch series but I wanted to throw it out > now to make sure the general structure was good.
Looks OK. I'm tempted to suggest that we should pull the default code out into separate functions and then at the top of arm_load_kernel() do if (!info->write_secondary_boot) { info->write_secondary_boot = default_write_secondary_boot; } if (!info->secondary_cpu_reset_hook) { info->secondary_cpu_reset_hook = default_secondary_cpu_reset_hook; } Then we can put all the secondary-cpu-related code that is in arm_boot.c in one place in the file. Probably also nice to add a comment about which fields in arm_boot_info are only required if you're using the default write_secondary_boot. -- PMM