CHANGELOG: v2 -> v3:
* take the file existence check outside of module_load_file, rename module_load_file to module_load_dso, will be called only on an existing file. This will simplify the return value. (Richard) v1 -> v2: * do not treat the display help text any differently and do report module load _errors_. If the module does not exist (ENOENT, ENOTDIR), no error will be produced. DESCRIPTION: while investigating a permission issue in accel, where accel-tcg-x86_64.so was not accessible, I noticed that no errors were produced regarding the module load failure. This series attempts to improve module_load_one and module_load_qom_one to handle the error cases better and produce some errors. Patch 1 is already reviewed and is about removing an unused existing argument "mayfail" from the call stack. Patch 2 is the real meat, and that one I would say is RFC. Will follow up with comments on the specific questions I have. Patch 3 finally adds a simple check in accel/, aborting if a module is not found, but relying on the existing error report from module_load_qom_one. Claudio Fontana (3): module: removed unused function argument "mayfail" module: add Error arguments to module_load_one and module_load_qom_one accel: abort if we fail to load the accelerator plugin accel/accel-softmmu.c | 8 ++- audio/audio.c | 6 +- block.c | 12 +++- block/dmg.c | 10 ++- hw/core/qdev.c | 10 ++- include/qemu/module.h | 27 ++++++-- qom/object.c | 15 ++++- softmmu/qtest.c | 6 +- ui/console.c | 18 ++++- util/module.c | 152 +++++++++++++++++++++++++----------------- 10 files changed, 183 insertions(+), 81 deletions(-) -- 2.26.2