Add a helper for qemu_fdt_setprop_strings() to take a set of strings to put into a device-tree, which removes several open-coded methods such as setting an char arr[] = {..} or setting char val[] = "str\0str2";
This is for hw/arm, hw/mips and hw/riscv as well as a couple of cores. It is not fully tested over all of those, I may not have caught all places this is to be replaced. Changes: v4: - fix checkpatch issues - remove error checking in hw/core/guest-loader.c v3: - fix return value for the call - add better help text v2: - fix node/path in comment