On 3/28/22 14:14, matheus.fe...@eldorado.org.br wrote:
+static uint64_t partsN(float_to_uint2)(FloatPartsN *p, FloatRoundMode rmode, + int scale, float_status *s, uint64_t *lo) +{ + int flags = 0; + uint64_t hi;
I think most of this would read cleaner with 'lo' as a local variable, assigned to *plo at the end (or, at the end, combined into the Int128 return value).
Otherwise, Reviewed-by: Richard Henderson <richard.hender...@linaro.org> r~