Hi, This series removes a redudant 'num_cs' field in the Aspeed SMC model and does a few cleanups on the way.
Thanks, C. Cédric Le Goater (6): aspeed/smc: Use max number of CE instead of 'num_cs' aspeed: Rework aspeed_board_init_flashes() interface aspeed/smc: Remove 'num_cs' field aspeed/smc: Rename 'max_peripherals' to 'max_cs' aspeed/smc: Let the SSI core layer define the bus name aspeed/smc: Fix error log include/hw/ssi/aspeed_smc.h | 3 +-- hw/arm/aspeed.c | 13 ++++----- hw/arm/aspeed_ast2600.c | 2 -- hw/arm/aspeed_soc.c | 2 -- hw/ssi/aspeed_smc.c | 53 ++++++++++++++++--------------------- 5 files changed, 29 insertions(+), 44 deletions(-) -- 2.34.1