Hi v4: - brown paperbug on qemu_file_skip()
static void qemu_file_skip(QEMUFile *f, int size) { - if (f->buf_index + size < f->buf_size) { + if (f->buf_index + size <= f->buf_size) { f->buf_index += size; } } v3: - fix return value on qemu_get_buffer. Anthony, all reviewers comments are fixed, please consider to apply. Later, Juan. v2: - rename "used" to "remaining" (Alex suggestion) - implement qemu_get_{byte,buffer} on top of qemu_peek_{byte, buffer} (Anthony suggestion) - fix qemu_peek_buffe_logic (Alex discovered the problem) v1: This series move the subsections detection code form: - Look that it starts form 5 To: - Look that it starts form 5 (SUBSECTION) - Look at the length - Look that length is bigger than section name - Look at the idstr and see that it starts with the subsection name. Please review. Later, Juan. *** BLURB HERE *** Juan Quintela (5): savevm: teach qemu_fill_buffer to do partial refills savevm: some coding style cleanups savevm: define qemu_get_byte() using qemu_peek_byte() savevm: improve subsections detection on load Revert "savevm: fix corruption in vmstate_subsection_load()." savevm.c | 144 ++++++++++++++++++++++++++++++++++++++++--------------------- 1 files changed, 94 insertions(+), 50 deletions(-) -- 1.7.6.4