Igor Mammedov <imamm...@redhat.com> writes: >> > >> > Please try reusing scratch CPU approach, see >> > kvm_arm_get_host_cpu_features() >> > for an example. You will very likely end up with simpler series, >> > compared to reinventing wheel. >> >> Even if I do that (and I serioulsy doubt it's going to be easier than >> just adding two 'u64's, kvm_arm_get_host_cpu_features() alone is 200 > it does a lot more then what you need, kvm_arm_create_scratch_host_vcpu() > which it uses will do the job and even that could be made smaller > for hv usecase. > >> lines long) this is not going to give us what we need to distinguish >> between >> >> 'hv-passthrough,hv-evmcs' >> >> and >> >> 'hv-passthrough' >> >> when 'hv-evmcs' *is* supported by the host. When guest CPU lacks VMX we >> don't want to enable it unless it was requested explicitly (former but >> not the later). > could you elaborate more on it, i.e. why do we need to distinguish and why > do we need evmcs without VMX if user asked for it (will it be usable) >
We need to distinguish because that would be sane. Enlightened VMCS is an extension to VMX, it can't be used without it. Genuine Hyper-V doesn't have a knob for enabling and disabling it, it comes with nesting (-ExposeVirtualizationExtensions $true). When we create a default set of Hyper-V enlightenments (either 'hv-default' or 'hv-passthrough') we should be as close as possible to genuine Hyper-V to not create unsupported Frankenstiens which can break with any Windows update (because nobody tested these configurations). That bein said, if guest CPU lacks VMX it is counter-productive to expose EVMCS. However, there is a problem with explicit enablement: what should 'hv-passthrough,hv-evmcs' option do? Just silently drop EVMCS? Doesn't sound sane to me. >> Moreover, instead of just adding two 'u64's we're now doing an ioctl >> which can fail, be subject to limits,... Creating and destroying a CPU >> is also slow. Sorry, I hardly see how this is better, maybe just from >> 'code purity' point of view. > readable and easy to maintain code is not a thing to neglect. Of couse, but 'scratch CPU' idea is not a good design decision, it is an ugly hack we should get rid of in ARM land, not try bringing it to other architectures. Generally, KVM should allow to query all its capabilities without the need to create a vCPU or, if not possible, we should create 'real' QEMU VCPUs and use one/all of the to query capabilities, avoiding 'scratch' because: - Creating and destroying a vCPU makes VM startup slower, much slower. E.g. for a single-CPU VM you're doubling the time required to create vCPUs! - vCPUs in KVM are quite memory consuming. Just 'struct kvm_vcpu_arch' was something like 12kb last time I looked at it. I have no clue why scratch vCPUs were implemented on ARM, however, I'd very much want us to avoid doing the same on x86. We do have use-cases where startup time and consumed memory is important. There is a point in limiting ioctls for security reasons (e.g. if I'm creating a single vCPU VM I may want to limit userspace process to one and only one KVM_CREATE_VCPU call). Now to the code you complain about. The 'hard to read and maintain' code is literaly this: +static void x86_hv_feature_set(Object *obj, bool value, int feature) +{ + X86CPU *cpu = X86_CPU(obj); + + if (value) { + cpu->hyperv_features |= BIT(feature); + cpu->hyperv_features_on |= BIT(feature); + cpu->hyperv_features_off &= ~BIT(feature); + } else { + cpu->hyperv_features &= ~BIT(feature); + cpu->hyperv_features_on &= ~BIT(feature); + cpu->hyperv_features_off |= BIT(feature); + } +} I can add as many comments here as needed, however, I don't see what requires additional explanaition. We just want to know two things: - What's the 'effective' setting of the control - Was it explicitly enabled or disabled on the command line. Custom parsers are not new in QEMU and they're not going anywhere I believe. There are options with simple enablent and there are some with additional considerations. Trying to make CPU objects somewhat 'special' by forcing all options to be of type-1 (and thus crippling user experience) is not the way to go IMHO. I'd very much like us to go in another direction, make our option parser better so my very simple use-case is covered 'out-of-the-box'. -- Vitaly