On 9/25/20 2:03 AM, Helio Loureiro wrote:
Hi,
I would replace the word variable "kind" by "category".
Hi, welcome to the list!
For patch reviews, we try to reply in-line, below the original post.
I'm not attached to 'kind', but 'category' is perhaps too broad.
Category in this particular domain might refer to the difference between
a "Directive" (include, pragma) and a Definition (enum, struct, union,
alternate, command, event)
(For more information on the QAPI Schema Language that we are parsing
and validating here, see docs/devel/qapi-code-gen.txt if you are
curious. Ultimately it is a JSON-like format that permits multiple
objects per document and allows comments. We use these structures to
generate types and command interfaces for our API protocol, QMP.)
Ultimately I am using 'kind' for the 'type of expression', but type is
an extremely overloaded word when parsing a language in another language!
We also use 'meta' nearby for semantically the same thing, but with
different typing.
Thanks for looking!
--js
./helio
On Fri, Sep 25, 2020, 03:32 John Snow <js...@redhat.com
<mailto:js...@redhat.com>> wrote:
On 9/24/20 9:18 PM, Cleber Rosa wrote:
> I have to say the style of this line bothers me, but it's just that,
> style. So,
What don't you like?