Patchew URL: https://patchew.org/QEMU/20200922083821.578519-1-phi...@redhat.com/
Hi, This series seems to have some coding style problems. See output below for more information: Type: series Message-id: 20200922083821.578519-1-phi...@redhat.com Subject: [PATCH v2 0/6] block/nvme: Map doorbells pages write-only, remove magic from nvme_init === TEST SCRIPT BEGIN === #!/bin/bash git rev-parse base > /dev/null || exit 0 git config --local diff.renamelimit 0 git config --local diff.renames True git config --local diff.algorithm histogram ./scripts/checkpatch.pl --mailback base.. === TEST SCRIPT END === Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384 From https://github.com/patchew-project/qemu - [tag update] patchew/1600485023-263643-1-git-send-email-lei....@intel.com -> patchew/1600485023-263643-1-git-send-email-lei....@intel.com - [tag update] patchew/20200918092203.20384-1-chen.zh...@intel.com -> patchew/20200918092203.20384-1-chen.zh...@intel.com - [tag update] patchew/20200921144957.979989-1-lviv...@redhat.com -> patchew/20200921144957.979989-1-lviv...@redhat.com - [tag update] patchew/20200921174320.46062-1-th...@redhat.com -> patchew/20200921174320.46062-1-th...@redhat.com - [tag update] patchew/20200921221045.699690-1-ehabk...@redhat.com -> patchew/20200921221045.699690-1-ehabk...@redhat.com * [new tag] patchew/20200922083821.578519-1-phi...@redhat.com -> patchew/20200922083821.578519-1-phi...@redhat.com Switched to a new branch 'test' ba5ba7b block/nvme: Replace magic value by SCALE_MS definition 7975c85 block/nvme: Use register definitions from 'block/nvme.h' 0ce328b block/nvme: Drop NVMeRegs structure, directly use NvmeBar 554f68e block/nvme: Reduce I/O registers scope 5cfb159 block/nvme: Map doorbells pages write-only 2064703 util/vfio-helpers: Pass page protections to qemu_vfio_pci_map_bar() === OUTPUT BEGIN === 1/6 Checking commit 2064703ff8dc (util/vfio-helpers: Pass page protections to qemu_vfio_pci_map_bar()) 2/6 Checking commit 5cfb15932539 (block/nvme: Map doorbells pages write-only) 3/6 Checking commit 554f68e25abc (block/nvme: Reduce I/O registers scope) 4/6 Checking commit 0ce328b78083 (block/nvme: Drop NVMeRegs structure, directly use NvmeBar) ERROR: Use of volatile is usually wrong, please add a comment #43: FILE: block/nvme.c:692: + volatile NvmeBar *regs = NULL; total: 1 errors, 0 warnings, 62 lines checked Patch 4/6 has style problems, please review. If any of these errors are false positives report them to the maintainer, see CHECKPATCH in MAINTAINERS. 5/6 Checking commit 7975c85b3904 (block/nvme: Use register definitions from 'block/nvme.h') 6/6 Checking commit ba5ba7b65742 (block/nvme: Replace magic value by SCALE_MS definition) === OUTPUT END === Test command exited with code: 1 The full log is available at http://patchew.org/logs/20200922083821.578519-1-phi...@redhat.com/testing.checkpatch/?type=message. --- Email generated automatically by Patchew [https://patchew.org/]. Please send your feedback to patchew-de...@redhat.com