On 2020/6/23 下午5:34, Cindy Lu wrote:
On Tue, Jun 23, 2020 at 3:21 PM Jason Wang<jasow...@redhat.com>  wrote:
On 2020/6/22 下午11:37, Cindy Lu wrote:
use the vhost_dev_start callback to send the status to backend
I suggest to squash this into previous patch.

Sure will do
Signed-off-by: Cindy Lu<l...@redhat.com>
---
   hw/virtio/vhost.c         | 17 +++++++++++++++++
   include/hw/virtio/vhost.h |  2 ++
   2 files changed, 19 insertions(+)

diff --git a/hw/virtio/vhost.c b/hw/virtio/vhost.c
index 01ebe12f28..bfd7f9ce1f 100644
--- a/hw/virtio/vhost.c
+++ b/hw/virtio/vhost.c
@@ -744,6 +744,7 @@ static void vhost_iommu_region_del(MemoryListener *listener,
       }
   }

+
   static int vhost_virtqueue_set_addr(struct vhost_dev *dev,
                                       struct vhost_virtqueue *vq,
                                       unsigned idx, bool enable_log)
@@ -1661,6 +1662,11 @@ int vhost_dev_start(struct vhost_dev *hdev, VirtIODevice 
*vdev)
           }
       }

+    r = vhost_set_start(hdev, true);
I think we need a better name for this function.

Shall we change it to vhost_set_device_start ? Since the
vhost_dev_start was occupied by other function


Or maybe just open code the vhost_set_start here since there's no other users.

Thanks



Reply via email to