Hi all! This is the first part of the bit series, which contains mostly simple cleanups.
v6 was sent in separate (I'm sorry for inconvenience) v7: by Markus review (and with his prepared fixups, thanks a lot!): - don't rename Error** paramters - switch to Error *const * where appropriate last patch is new and replaces "nbd: well form nbd_iter_channel_error errp handler" Vladimir Sementsov-Ogievskiy (21): hw/core/loader-fit: fix freeing errp in fit_load_fdt net/net: Clean up variable shadowing in net_client_init() error: rename errp to errp_in where it is IN-argument hmp: drop Error pointer indirection in hmp_handle_error vnc: drop Error pointer indirection in vnc_client_io_error qdev-monitor: well form error hint helpers ppc: well form kvmppc_hint_smt_possible error hint helper 9pfs: well form error hint helpers hw/core/qdev: cleanup Error ** variables block/snapshot: rename Error ** parameter to more common errp hw/i386/amd_iommu: rename Error ** parameter to more common errp qga: rename Error ** parameter to more common errp monitor/qmp-cmds: rename Error ** parameter to more common errp hw/s390x: rename Error ** parameter to more common errp hw/sd: drop extra whitespace in sdhci_sysbus_realize() header hw/tpm: rename Error ** parameter to more common errp hw/usb: rename Error ** parameter to more common errp include/qom/object.h: rename Error ** parameter to more common errp backends/cryptodev: drop local_err from cryptodev_backend_complete() hw/vfio/ap: drop local_err from vfio_ap_realize nbd: assert that Error** is not NULL in nbd_iter_channel_error Cc: "Gonglei (Arei)" <arei.gong...@huawei.com> Cc: Eric Blake <ebl...@redhat.com> Cc: Kevin Wolf <kw...@redhat.com> Cc: Max Reitz <mre...@redhat.com> Cc: "Marc-André Lureau" <marcandre.lur...@redhat.com> Cc: Greg Kurz <gr...@kaod.org> Cc: Paul Burton <pbur...@wavecomp.com> Cc: Aleksandar Rikalo <aleksandar.rik...@rt-rk.com> Cc: Paolo Bonzini <pbonz...@redhat.com> Cc: "Daniel P. Berrangé" <berra...@redhat.com> Cc: Eduardo Habkost <ehabk...@redhat.com> Cc: Richard Henderson <r...@twiddle.net> Cc: "Michael S. Tsirkin" <m...@redhat.com> Cc: Marcel Apfelbaum <marcel.apfelb...@gmail.com> Cc: David Gibson <da...@gibson.dropbear.id.au> Cc: Cornelia Huck <coh...@redhat.com> Cc: David Hildenbrand <da...@redhat.com> Cc: Halil Pasic <pa...@linux.ibm.com> Cc: Christian Borntraeger <borntrae...@de.ibm.com> Cc: "Philippe Mathieu-Daudé" <phi...@redhat.com> Cc: Stefan Berger <stef...@linux.ibm.com> Cc: Gerd Hoffmann <kra...@redhat.com> Cc: Tony Krowiak <akrow...@linux.ibm.com> Cc: Pierre Morel <pmo...@linux.ibm.com> Cc: Alex Williamson <alex.william...@redhat.com> Cc: Markus Armbruster <arm...@redhat.com> Cc: Michael Roth <mdr...@linux.vnet.ibm.com> Cc: "Dr. David Alan Gilbert" <dgilb...@redhat.com> Cc: Jason Wang <jasow...@redhat.com> Cc: qemu-devel@nongnu.org Cc: qemu-bl...@nongnu.org Cc: qemu-...@nongnu.org Cc: qemu-s3...@nongnu.org include/block/snapshot.h | 2 +- include/monitor/hmp.h | 2 +- include/qapi/error.h | 6 +- include/qom/object.h | 4 +- target/ppc/kvm_ppc.h | 4 +- ui/vnc.h | 2 +- backends/cryptodev.c | 11 +-- block/nbd.c | 1 + block/snapshot.c | 4 +- dump/dump-hmp-cmds.c | 4 +- hw/9pfs/9p-local.c | 2 +- hw/9pfs/9p-proxy.c | 2 +- hw/core/loader-fit.c | 5 +- hw/core/machine-hmp-cmds.c | 6 +- hw/core/qdev.c | 28 ++++--- hw/i386/amd_iommu.c | 14 ++-- hw/ppc/spapr.c | 2 +- hw/s390x/event-facility.c | 2 +- hw/s390x/s390-stattrib.c | 3 +- hw/sd/sdhci.c | 2 +- hw/tpm/tpm_emulator.c | 8 +- hw/usb/dev-network.c | 2 +- hw/vfio/ap.c | 9 +-- monitor/hmp-cmds.c | 155 ++++++++++++++++++------------------- monitor/qmp-cmds.c | 2 +- net/net.c | 17 ++-- qdev-monitor.c | 16 ++-- qga/commands-posix.c | 2 +- qga/commands-win32.c | 2 +- qga/commands.c | 12 +-- qom/qom-hmp-cmds.c | 4 +- target/ppc/kvm.c | 2 +- ui/vnc.c | 20 ++--- util/error.c | 6 +- 34 files changed, 173 insertions(+), 190 deletions(-) -- 2.21.0