On 9/11/19 6:55 AM, Tony Nguyen wrote: >> typedef uint64_t FullLoadHelper(CPUArchState *env, target_ulong addr, >> TCGMemOpIdx oi, uintptr_t retaddr); >> +typedef uint64_t DirectLoadHelper(const void *); > > Would 'Load' instead of 'DirectLoadHelper' have enough clarity?
I suppose so, yes. > If so, consider also dropping the 'direct_' prefix in the functions below. > >> + >> +static inline uint64_t direct_ldub(const void *haddr) >> +{ >> + return *(uint8_t *)haddr; >> +} >> + >> +static inline uint64_t direct_lduw_be(const void *haddr) >> +{ >> + return lduw_be_p(haddr); >> +} I would be hesitant to call this just "lduw_be"; I think that's confusing when it's calling lduw_be_p. But perhaps "wrap_*" or "wide_*"? r~