This is the second in a multi-series effort to make virtiofsd thread-safe. The main goal in this installment is to make lo_inode thread-safe, but other fixes are included too. Like any good author I will build suspense and won't tell where this story is headed, but I still have some more code auditing to do before we can declare virtiofsd thread-safe :).
Based-on: <20190726091103.23503-1-stefa...@redhat.com> ("virtiofsd: multithreading preparation") Stefan Hajnoczi (5): virtiofsd: take lo->mutex around lo_add_fd_mapping() virtiofsd: take lo->mutex around lo_add_dirp_mapping() virtiofsd: rename inode->refcount to inode->nlookup virtiofsd: fix inode nlookup leaks virtiofsd: introduce inode refcount to prevent use-after-free contrib/virtiofsd/passthrough_ll.c | 262 +++++++++++++++++++++++------ 1 file changed, 214 insertions(+), 48 deletions(-) -- 2.21.0