On 5/30/19 6:26 AM, Peter Maydell wrote:
>> -#define TCG_TARGET_HAS_cmpsel_vec       0
>> +#define TCG_TARGET_HAS_cmpsel_vec       -1
> 
> This is the only place where we define a TCG_TARGET_HAS_* macro
> to something other than 0 or 1, which means that Coverity
> complains (CID 1401702) when we use it in a logical boolean expression
>   return have_vec && TCG_TARGET_HAS_cmpsel_vec;
> later on.
> 
> Should it really be -1, or is this a typo for 1 ?

It really should be -1.
See commit 25c012b4009256505be3430480954a0233de343e,
which contains the rationale.


r~

Reply via email to