On Wed, 17 Apr 2019 13:31:43 +0200 David Hildenbrand <da...@redhat.com> wrote:
> Rename qemu_getrampagesize() to qemu_minrampagesize(). While at it, > properly rename find_max_supported_pagesize() to > find_min_backend_pagesize(). > > s390x is actually interested into the maximum ram pagesize, so > introduce and use qemu_maxrampagesize(). > > Add a TODO, indicating that looking at any mapped memory backends is not > 100% correct in some cases. > > Signed-off-by: David Hildenbrand <da...@redhat.com> > --- > exec.c | 44 ++++++++++++++++++++++++++++++++++---- > hw/ppc/spapr_caps.c | 4 ++-- > hw/s390x/s390-virtio-ccw.c | 2 +- > hw/vfio/spapr.c | 2 +- > include/exec/ram_addr.h | 3 ++- > target/ppc/kvm.c | 2 +- > 6 files changed, 47 insertions(+), 10 deletions(-) This now has two R-bs, so unless somebody speaks up against it, I'll just take this through the s390x tree together with patch 1.