My initial goal was simple: removing the qdev_get_machine() call from ppc_cpu_parse_featurestr() because I want to make qdev_get_machine() available only to softmmu code.
Before doing this, I had to make *-user not call CPUClass::parse_features() anymore (it was pointless to call it, anyway). While doing this, I decided to rename parse_cpu_model() to something clearer (parse_cpu_option()). As a nice side effect, now the dependency between machine object creation and parse_cpu_option() is not hidden anymore. Eduardo Habkost (5): cpu: Rename parse_cpu_model() to parse_cpu_option() cpu: Extract CPU class lookup from parse_cpu_option() linux-user: Use lookup_cpu_class() bsd-user: Use lookup_cpu_class() cpu: Add MachineState parameter to parse_features() include/qom/cpu.h | 18 ++++++++++++++---- target/ppc/cpu-qom.h | 3 ++- bsd-user/main.c | 4 +++- exec.c | 28 +++++++++++++++------------- linux-user/main.c | 4 +++- qom/cpu.c | 3 ++- target/i386/cpu.c | 3 ++- target/ppc/translate_init.inc.c | 7 ++++--- target/sparc/cpu.c | 3 ++- vl.c | 19 ++++++++++--------- 10 files changed, 57 insertions(+), 35 deletions(-) -- 2.18.0.rc1.1.g3f1ff2140