On Wed, Jun 27, 2018 at 11:38:17AM +1000, Benjamin Herrenschmidt wrote: > On Wed, 2018-06-27 at 03:35 +0300, Michael S. Tsirkin wrote: > > > > > + > > > +/* Extract field fname from val */ > > > +#define GETFIELD(fname, val) \ > > > + (((val) & fname##_MASK) >> fname##_LSH) > > > + > > > +/* Set field fname of oval to fval > > > + * NOTE: oval isn't modified, the combined result is returned > > > + */ > > > +#define SETFIELD(fname, oval, fval) \ > > > + (((oval) & ~fname##_MASK) | \ > > > + ((((typeof(oval))(fval)) << fname##_LSH) & fname##_MASK)) > > > + > > > > Pls don't make up macros like these. We can't have each device do it. > > So what ? We move the macros in a generic place ? These are MUCH better > than open-coding the masks & shifts and much less error prone.
include/qemu/bitops.h has a ton of handy macros. > > > @@ -1031,6 +1110,7 @@ static Property pnv_chip_properties[] = { > > > DEFINE_PROP_UINT64("ram-size", PnvChip, ram_size, 0), > > > DEFINE_PROP_UINT32("nr-cores", PnvChip, nr_cores, 1), > > > DEFINE_PROP_UINT64("cores-mask", PnvChip, cores_mask, 0x0), > > > + DEFINE_PROP_UINT32("num-phbs", PnvChip, num_phbs, 1), > > > DEFINE_PROP_END_OF_LIST(), > > > }; > > > > How about instanciating each extra phb using -device? > > Seems better than teaching everyone about platform-specific > > options. > > It's about which PHBs are enabled, not which are instanciated, if I > understand Cedric changes ... > > This aims are implementing the POWER8 chip correctly, it has a fixed > number of PHBs per-chip at very specific XSCOM addresses, that the > firwmare knows about. > > Cheers, > Ben.