On 06/19/2018 12:34 AM, Peter Xu wrote:
The old names are confusing since both of the old functions are poping

s/poping/popping/

an item from multiple queues rather than a single queue.  In that
sense, *_pop_any() suites better than *_pop_one().

Since at it, touch up the function monitor_qmp_response_pop_any() a bit
to let the callers pass in a QMPResponse struct instead of returning a
struct.  Change the return value to boolean to mark whether we have
poped a valid response instead.

s/poped/popped/


Suggested-by: Markus Armbruster <arm...@redhat.com>
Signed-off-by: Peter Xu <pet...@redhat.com>
---
  monitor.c | 20 +++++++++-----------
  1 file changed, 9 insertions(+), 11 deletions(-)


--
Eric Blake, Principal Software Engineer
Red Hat, Inc.           +1-919-301-3266
Virtualization:  qemu.org | libvirt.org

Reply via email to