On 13/06/2018 07:05, Thomas Huth wrote: > diff --git a/tests/vmgenid-test.c b/tests/vmgenid-test.c > index 8d915c6..4324034 100644 > --- a/tests/vmgenid-test.c > +++ b/tests/vmgenid-test.c > @@ -131,7 +131,7 @@ static void read_guid_from_monitor(QemuUUID *guid) > static char disk[] = "tests/vmgenid-test-disk-XXXXXX"; > > #define GUID_CMD(guid) \ > - "-machine accel=kvm:tcg " \ > + "-accel kvm:tcg " \ > "-device vmgenid,id=testvgid,guid=%s " \
"-accel kvm:tcg" works, but it really shouldn't (and I think we can change it without a deprecation period). The right syntax would be "-accel kvm -accel tcg", so that you can specify options that are valid only for KVM, or onlty for TCG. Paolo