On Thu, Mar 29, 2018 at 03:05:09PM +0200, Igor Mammedov wrote: > On Wed, 28 Mar 2018 15:54:28 -0300 > Eduardo Habkost <ehabk...@redhat.com> wrote: > > > On Tue, Mar 27, 2018 at 03:08:27PM +0200, Igor Mammedov wrote: > > > On Fri, 23 Mar 2018 17:42:18 -0300 > > > Eduardo Habkost <ehabk...@redhat.com> wrote: > > > > > > > On Mon, Mar 12, 2018 at 02:11:08PM +0100, Igor Mammedov wrote: > > > > > it will allow to reuse parse_NumaOptions() for parsing > > > > > configuration commands received via QMP interface > > > > > > > > > > Signed-off-by: Igor Mammedov <imamm...@redhat.com> > > > > > --- > > > > > include/sysemu/numa.h | 1 + > > > > > numa.c | 48 > > > > > +++++++++++++++++++++++++++++------------------- > > > > > 2 files changed, 30 insertions(+), 19 deletions(-) > > > > > > > > > > diff --git a/include/sysemu/numa.h b/include/sysemu/numa.h > > > > > index 21713b7..7a0ae75 100644 > > > > > --- a/include/sysemu/numa.h > > > > > +++ b/include/sysemu/numa.h > > > > > @@ -22,6 +22,7 @@ struct NumaNodeMem { > > > > > }; > > > > > > > > > > extern NodeInfo numa_info[MAX_NODES]; > > > > > +int parse_numa(void *opaque, QemuOpts *opts, Error **errp); > > > > > void parse_numa_opts(MachineState *ms); > > > > > void numa_complete_configuration(MachineState *ms); > > > > > void query_numa_node_mem(NumaNodeMem node_mem[]); > > > > > diff --git a/numa.c b/numa.c > > > > > index 126c649..2b1d292 100644 > > > > > --- a/numa.c > > > > > +++ b/numa.c > > > > > @@ -169,28 +169,11 @@ static void parse_numa_distance(NumaDistOptions > > > > > *dist, Error **errp) > > > > > have_numa_distance = true; > > > > > } > > > > > > > > > > -static int parse_numa(void *opaque, QemuOpts *opts, Error **errp) > > > > > +static > > > > > +void parse_NumaOptions(MachineState *ms, NumaOptions *object, Error > > > > > **errp) > > > > > > > > I wonder if we should rename the parse_numa_{node,distance}() > > > > functions to configure_numa_{node,distance}(), and this one > > > > configure_numa(). These functions don't parse anything, anymore. > > > I'd preffer to do it in another patch on top of this series > > > (added it my TODO list) > > > > I agree with renaming parse_numa*() later, but the new function > > you are creating can have a more reasonable name as it doesn't > > parse anything. > > > how about: s/parse_NumaOptions/set_NumaOptions/
No strong preference. "register", "configure", "set" would all be good enough to me. I would avoid the weird underline_and_CamelCase naming style, though (this style seems to be used only by generated QAPI code). -- Eduardo