Series first cleanups ACPI code around build_fadt() and then converts current packed structure approach to a build_append_FOO() API, getting rid of error prone explicit endianness conversions in code and making build_fadt() look more like APCI table declaration from spec, which should be easier to read/maintain. After that build_fadt() becomes generic enough that we could drop ARM specific implementation and reuse generic build_fadt(), reducing code duplication.
PS: tested only x86 which has make check coverage, ARM was only slightly tested. git tree for testing: https://github.com/imammedo/qemu.git fadt_refactoring_v1 CC: "Michael S. Tsirkin" <m...@redhat.com> CC: Shannon Zhao <zhaoshengl...@huawei.com> CC: Peter Maydell <peter.mayd...@linaro.org> CC: Andrew Jones <drjo...@redhat.com> CC: qemu-devel@nongnu.org CC: qemu-...@nongnu.org Igor Mammedov (9): acpi: remove unused acpi-dsdt.aml pc: replace pm object initialization with one-liner in acpi_get_pm_info() acpi: reuse AcpiGenericAddress instead of Acpi20GenericAddress acpi: add build_append_gas() helper for Generic Address Structure pc: acpi: isolate FADT specific data into AcpiFadtData structure pc: acpi: use build_append_foo() API to construct FADT acpi: move build_fadt() from i386 specific to generic ACPI source virt_arm: acpi: reuse common build_fadt() tests: acpi: don't read all fields in test_acpi_fadt_table() include/hw/acpi/acpi-defs.h | 136 +++++++----------------------- include/hw/acpi/aml-build.h | 23 ++++++ Makefile | 1 - hw/acpi/aml-build.c | 140 +++++++++++++++++++++++++++++++ hw/arm/virt-acpi-build.c | 39 ++++----- hw/i386/acpi-build.c | 197 ++++++++++++++------------------------------ pc-bios/acpi-dsdt.aml | Bin 4405 -> 0 bytes tests/bios-tables-test.c | 82 ++++-------------- 8 files changed, 292 insertions(+), 326 deletions(-) delete mode 100644 pc-bios/acpi-dsdt.aml -- 2.7.4