On Tue 16 Jan 2018 11:10:37 PM CET, Eric Blake wrote: >> static inline int64_t align_offset(int64_t offset, int n) >> { >> offset = (offset + n - 1) & ~(n - 1); > > Unrelated to this commit, but should we switch this to use > QEMU_ALIGN_UP() instead of open-coding it?
Why not, we can actually use ROUND_UP() instead which is optimized for powers of two. I can send the patch. Berto