Hi, This series seems to have some coding style problems. See output below for more information:
Type: series Message-id: 20180114104751.21965-1-mark.cave-ayl...@ilande.co.uk Subject: [Qemu-devel] [PATCH 00/11] sun4u: APB tidy-up/rename and tracepoint conversions === TEST SCRIPT BEGIN === #!/bin/bash BASE=base n=1 total=$(git log --oneline $BASE.. | wc -l) failed=0 git config --local diff.renamelimit 0 git config --local diff.renames True commits="$(git log --format=%H --reverse $BASE..)" for c in $commits; do echo "Checking PATCH $n/$total: $(git log -n 1 --format=%s $c)..." if ! git show $c --format=email | ./scripts/checkpatch.pl --mailback -; then failed=1 echo fi n=$((n+1)) done exit $failed === TEST SCRIPT END === Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384 Switched to a new branch 'test' 68e33f523f sparc64: convert hw/sparc64/sparc64.c from DPRINTF macros to trace events 3ac895348d sabre: convert from SABRE_DPRINTF macro to trace-events 5b44f0019e pci: add trace-events support for hw/pci-host a625765105 apb: rename apb.c to sabre.c 8ef3083a55 sun4u: rename apb variables and constants 349fc89fe8 apb: rename QOM type from TYPE_APB to TYPE_SABRE 74cbac48cd apb: QOMify sabre PCI host bridge 787f76fc03 apb: change pbm_pci_host prefix functions to use sabre_pci prefix 65b67f4892 apb: rename APB functions to use sabre prefix 3bdf1030e7 simba: rename PBMPCIBridge and QOM types to reflect simba naming b645abcfb6 apb: split simba PCI bridge into hw/pci-bridge/simba.c === OUTPUT BEGIN === Checking PATCH 1/11: apb: split simba PCI bridge into hw/pci-bridge/simba.c... Checking PATCH 2/11: simba: rename PBMPCIBridge and QOM types to reflect simba naming... Checking PATCH 3/11: apb: rename APB functions to use sabre prefix... Checking PATCH 4/11: apb: change pbm_pci_host prefix functions to use sabre_pci prefix... Checking PATCH 5/11: apb: QOMify sabre PCI host bridge... Checking PATCH 6/11: apb: rename QOM type from TYPE_APB to TYPE_SABRE... Checking PATCH 7/11: sun4u: rename apb variables and constants... Checking PATCH 8/11: apb: rename apb.c to sabre.c... ERROR: do not use C99 // comments #86: FILE: hw/pci-host/sabre.c:41: +//#define DEBUG_SABRE total: 1 errors, 0 warnings, 188 lines checked Your patch has style problems, please review. If any of these errors are false positives report them to the maintainer, see CHECKPATCH in MAINTAINERS. Checking PATCH 9/11: pci: add trace-events support for hw/pci-host... Checking PATCH 10/11: sabre: convert from SABRE_DPRINTF macro to trace-events... Checking PATCH 11/11: sparc64: convert hw/sparc64/sparc64.c from DPRINTF macros to trace events... === OUTPUT END === Test command exited with code: 1 --- Email generated automatically by Patchew [http://patchew.org/]. Please send your feedback to patchew-de...@freelists.org