On Thu, 5 Oct 2017 17:36:30 -0300 Eduardo Habkost <ehabk...@redhat.com> wrote:
> From: Dou Liyang <douly.f...@cn.fujitsu.com> > > It may be hard to read the assignment statement of "next_base", so > > S/next_base += (1ULL << 32) - pcms->below_4g_mem_size; > /next_base = mem_base + mem_len; > > ... for readability. > > No functionality change. > > Signed-off-by: Dou Liyang <douly.f...@cn.fujitsu.com> > Message-Id: <1504231805-30957-3-git-send-email-douly.f...@cn.fujitsu.com> > Signed-off-by: Eduardo Habkost <ehabk...@redhat.com> Pls, retest/respin once 2.12 dev window is open > --- > hw/i386/acpi-build.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/hw/i386/acpi-build.c b/hw/i386/acpi-build.c > index 2af37a9129..73e3443bce 100644 > --- a/hw/i386/acpi-build.c > +++ b/hw/i386/acpi-build.c > @@ -2381,7 +2381,7 @@ build_srat(GArray *table_data, BIOSLinker *linker, > MachineState *machine) > } > mem_base = 1ULL << 32; > mem_len = next_base - pcms->below_4g_mem_size; > - next_base += (1ULL << 32) - pcms->below_4g_mem_size; > + next_base = mem_base + mem_len; > } > numamem = acpi_data_push(table_data, sizeof *numamem); > build_srat_memory(numamem, mem_base, mem_len, i - 1,