On 09/10/2017 09:19 AM, Lluís Vilanova wrote:
>      while (true) {
> +        target_ulong pc_insn = db->pc_next;

Why not just "pc"?

> +
>          db->num_insns++;
>          ops->insn_start(db, cpu);
>          tcg_debug_assert(db->is_jmp == DISAS_NEXT);  /* no early exit */
> @@ -96,6 +98,7 @@ void translator_loop(const TranslatorOps *ops, 
> DisasContextBase *db,
>          if (db->num_insns == 1) {
>              trace_guest_bbl_before_tcg(cpu, tcg_ctx.tcg_env, db->pc_first);
>          }
> +        trace_guest_inst_before_tcg(cpu, tcg_ctx.tcg_env, pc_insn);

I prefer "insn" over "inst".  There are enough other words that begin with
"inst" (e.g. instance) to possibly be confusing.  Either that or it's my 20
years working on gcc that ingrained "insn".  ;-)


r~

Reply via email to