On Mon, May 08, 2017 at 05:57:34PM -0300, Eduardo Habkost wrote: > To make it consistent with the remaining soundhw.c functions and > avoid confusion with the audio_init() function in audio/audio.c, > rename audio_init() to soundhw_init(). > > Signed-off-by: Eduardo Habkost <ehabk...@redhat.com>
Reviewed-by: David Gibson <da...@gibson.dropbear.id.au> > --- > Changes v2 -> v3: > * Update hw/ppc/prep.c audio_init() call too > > Changes v1 -> v2: > * Rebase to latest qemu.git master > --- > include/hw/audio/audio.h | 2 +- > hw/audio/soundhw.c | 2 +- > hw/ppc/prep.c | 2 +- > vl.c | 2 +- > 4 files changed, 4 insertions(+), 4 deletions(-) > > diff --git a/include/hw/audio/audio.h b/include/hw/audio/audio.h > index 259bb2cf96..119f7d78d5 100644 > --- a/include/hw/audio/audio.h > +++ b/include/hw/audio/audio.h > @@ -7,7 +7,7 @@ void isa_register_soundhw(const char *name, const char *descr, > void pci_register_soundhw(const char *name, const char *descr, > int (*init_pci)(PCIBus *bus)); > > -void audio_init(void); > +void soundhw_init(void); > void select_soundhw(const char *optarg); > > #endif > diff --git a/hw/audio/soundhw.c b/hw/audio/soundhw.c > index 5e96b73c81..29565da93d 100644 > --- a/hw/audio/soundhw.c > +++ b/hw/audio/soundhw.c > @@ -129,7 +129,7 @@ void select_soundhw(const char *optarg) > } > } > > -void audio_init(void) > +void soundhw_init(void) > { > struct soundhw *c; > ISABus *isa_bus = (ISABus *) object_resolve_path_type("", TYPE_ISA_BUS, > NULL); > diff --git a/hw/ppc/prep.c b/hw/ppc/prep.c > index 96a4813b3f..4a7d2cfbe0 100644 > --- a/hw/ppc/prep.c > +++ b/hw/ppc/prep.c > @@ -783,7 +783,7 @@ static void ibm_40p_init(MachineState *machine) > &cmos_checksum); > > /* initialize audio subsystem */ > - audio_init(); > + soundhw_init(); > > /* add some more devices */ > if (defaults_enabled()) { > diff --git a/vl.c b/vl.c > index a2400e1ab6..42fd66ac0d 100644 > --- a/vl.c > +++ b/vl.c > @@ -4569,7 +4569,7 @@ int main(int argc, char **argv, char **envp) > > realtime_init(); > > - audio_init(); > + soundhw_init(); > > if (hax_enabled()) { > hax_sync_vcpus(); -- David Gibson | I'll have my music baroque, and my code david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_ | _way_ _around_! http://www.ozlabs.org/~dgibson
signature.asc
Description: PGP signature