Just a trivial couple of patches addressing minor style issues. Enforcing the correct order of operations (pop, unpop, push, rewind) with an assert, which was another potential change discussed previously, would add a non-trivial amount of code and is not worth the effort in my opinion. A simple linked-list of VirtQueueElement would not be enough because these are not in the ownership of the common virtio code. The effect of an out-of-order, yet valid, virtqueue_push would need to be encoded in the linked list even though the element has been deallocated. It's almost like maintaining a shadow available ring - doable but not justified at the moment.
Ladi Prosek (2): virtio: rename virtqueue_discard to virtqueue_unpop virtio: make virtqueue_alloc_element static