On 05.07.2016 17:24, Colin Lord wrote: > Isolate qed probe as part of the modularization process. > > Signed-off-by: Colin Lord <cl...@redhat.com> > --- > block/Makefile.objs | 2 +- > block/probe/qed.c | 18 ++++++++++++++++++ > block/qed.c | 15 +-------------- > include/block/probe.h | 1 + > 4 files changed, 21 insertions(+), 15 deletions(-) > create mode 100644 block/probe/qed.c
Reviewed-by: Max Reitz <mre...@redhat.com> > diff --git a/include/block/probe.h b/include/block/probe.h > index f9dd36e..e3e9934 100644 > --- a/include/block/probe.h > +++ b/include/block/probe.h > @@ -9,5 +9,6 @@ int dmg_probe(const uint8_t *buf, int buf_size, const char > *filename); > int parallels_probe(const uint8_t *buf, int buf_size, const char *filename); > int qcow_probe(const uint8_t *buf, int buf_size, const char *filename); > int qcow2_probe(const uint8_t *buf, int buf_size, const char *filename); > +int bdrv_qed_probe(const uint8_t *buf, int buf_size, const char *filename); Hmmm, maybe it would make sense to follow a consistent naming scheme here, i.e. either ${format}_probe() or bdrv_${format}_probe(). The latter is probably better, but the former is what most formats do, so... But maybe that is something that should be done in the "Separate X probe from its driver" patches. Max > > #endif >
signature.asc
Description: OpenPGP digital signature