On Wed, Jun 08, 2016 at 04:10:09PM +0200, Kevin Wolf wrote: > diff --git a/block/raw-aio.h b/block/raw-aio.h > index 714714e..1037502 100644 > --- a/block/raw-aio.h > +++ b/block/raw-aio.h > @@ -38,6 +38,8 @@ > typedef struct LinuxAioState LinuxAioState; > LinuxAioState *laio_init(void); > void laio_cleanup(LinuxAioState *s); > +int laio_submit_co(BlockDriverState *bs, LinuxAioState *s, int fd, > + int64_t sector_num, QEMUIOVector *qiov, int nb_sectors, int type);
Please add coroutine_fn. Please rename to laio_co_submit(), the naming convention is bdrv_co_foo() instead of bdrv_foo_co().
signature.asc
Description: PGP signature