On Wed, 06/01 15:08, Wei Jiangang wrote: > Use a single error_printf to replace triple error_report. > > Signed-off-by: Wei Jiangang <weijg.f...@cn.fujitsu.com> > --- > block/raw-posix.c | 10 +++++----- > 1 file changed, 5 insertions(+), 5 deletions(-) > > diff --git a/block/raw-posix.c b/block/raw-posix.c > index a4f5a1b..141b01a 100644 > --- a/block/raw-posix.c > +++ b/block/raw-posix.c > @@ -2061,11 +2061,11 @@ static bool setup_cdrom(char *bsd_path, Error **errp) > /* Prints directions on mounting and unmounting a device */ > static void print_unmounting_directions(const char *file_name) > { > - error_report("If device %s is mounted on the desktop, unmount" > - " it first before using it in QEMU", file_name); > - error_report("Command to unmount device: diskutil unmountDisk %s", > - file_name); > - error_report("Command to mount device: diskutil mountDisk %s", > file_name); > + error_printf("If device %s is mounted on the desktop, unmount" > + " it first before using it in QEMU\n" > + "Command to unmount device: diskutil unmountDisk %s\n" > + "Command to mount device: diskutil mountDisk %s\n", > + file_name, file_name, file_name);
I'd say it's less readable with a worse alignment to the parameters. Fam