Programmingkid <programmingk...@gmail.com> writes: > On Mar 2, 2016, at 4:32 AM, Markus Armbruster wrote: > >> Programmingkid <programmingk...@gmail.com> writes: >> >>> This patch adds the file MacKeys.h. It is a file that contains all the >>> constants >>> for the Macintosh keyboard keycodes. >>> >>> Signed-off-by: John Arbuckle <programmingk...@gmail.com> >>> >>> --- >>> Added standard license. >>> Added #ifndef #define #endif macros. >>> >>> include/hw/input/MacKeys.h | 168 >>> ++++++++++++++++++++++++++++++++++++++++++++ >> >> Please stick to lower case in file names. >> >> $ git-ls-files | grep '[A-Z][a-z]' | grep -v Makefile >> Changelog >> docs/vnc-ledstate-Pseudo-encoding.txt >> include/libdecnumber/decContext.h >> include/libdecnumber/decNumber.h >> include/libdecnumber/decNumberLocal.h >> include/libdecnumber/dpd/decimal128Local.h >> libdecnumber/decContext.c >> libdecnumber/decNumber.c > > Which one do you prefer: mackeys.h or macKeys.h ?
I'd call it mac-keys.h. mackeys.h would be okay. There's enough precedence for '_' in file names to justify mac_keys.h, but I personally dislike that.