On 16 February 2016 at 09:34, hitmoon <zxq_yx_...@163.com> wrote:
>
>
> 在 2016年02月16日 02:14, Peter Maydell 写道:
>>
>> On 27 January 2016 at 02:54, xiaoqiang zhao<zxq_yx_...@163.com>  wrote:
>>>
>>> >* split milkymist_sysctl_init into milkymist_sysctl_info.instance_init
>>> > and milkymist_sysctl_realize
>>
>> I think the "info" in this function name is wrong ?
>>
> I can not understand , can you give me more details?

The two functions which you have split the old
milkymist_sysctl_init() into are named "milkymist_sysctl_init()"
and "milkymist_sysctl_realize()". It confused me that you
said "split FUNCTION into STRUCT.FIELDNAME and FUNCTION";
I expected to read "split FUNCTION into FUNCTION and FUNCTION".

If you want you could just say
"Split the old SysBus init function into an instance_init
and a Device realize function."
(at the moment your two bullet points in the commit message
are actually both describing the same thing.)

thanks
-- PMM

Reply via email to