On 01/17/2014 10:44 AM, Peter Maydell wrote: > + switch (opcode) { > + case 0x6: /* CMGT, CMHI */ > + { > + NeonGenFn *ceqtstfns[3][2] = { ... > + case 0x7: /* CMGE, CMHS */ > + { > + NeonGenFn *ceqtstfns[3][2] = { ... > + case 0x11: /* CMTST, CMEQ */ > + { > + NeonGenFn *ceqtstfns[3][2] = {
Oh, and cut and paste on those names? Perhaps it would be less confusing to just name them all "fns" and let the specific code block imply the rest? r~