Am 04.12.2013 06:51, schrieb Peter Crosthwaite:
> On Wed, Dec 4, 2013 at 1:42 AM, Paolo Bonzini <pbonz...@redhat.com> wrote:
>> From: Hervé Poussineau <hpous...@reactos.org>
>>
>> We should not modify the type hash table while it is being iterated on.
>> Assert that it does not happen.
>>
>> Signed-off-by: Hervé Poussineau <hpous...@reactos.org>
>> Signed-off-by: Paolo Bonzini <pbonz...@redhat.com>
>> ---
>>  qom/object.c | 4 ++++
>>  1 file changed, 4 insertions(+)
>>
>> diff --git a/qom/object.c b/qom/object.c
>> index 3a43186..1dee9f0 100644
>> --- a/qom/object.c
>> +++ b/qom/object.c
>> @@ -78,8 +78,10 @@ static GHashTable *type_table_get(void)
>>      return type_table;
>>  }
>>
>> +static bool enumerating = false;
> 
> Global variable could probably use a more descriptive name.

I renamed it to enumerating_types and dropped the assignment as
suggested elsewhere by Alexey (a reply here would've been nice!).

I also took the liberty of inserted a white line to make the function
better readable.

Regards,
Andreas

-- 
SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany
GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer; HRB 16746 AG Nürnberg

Reply via email to