Hi,
+ if (pci_dev == NULL) { + hw_error("PCI: can't register device\n"); + }Can you please use !pci_dev for these checks?
Why? IMHO the code is more readable that way. It is easy to miss a single '!' character when reading the code, so I tend to write such tests in a more verbose fashion.
cheers, Gerd