This series move the event define to qapi code, so later other components could use it easily, it also make monitor code less and easier to decouple with other code.
Original patch comes from my series titles as [PATCH 00/13] trivial patches for event, error and monitor To focus more on one item, pick up the event patches alone. patch 6 was not merged to 4 since doc may be a bit much, so make it separate to focus on doc's correctness. Note: please pay a bit attention on patch 6's doc for shutdown, powerdown, stop, resume, suspend, suspend_disk, wakeup, to see if it is correct. I paid some time to find the difference, and doced it from my understanding. Esp shutdown and powerdown is not very clear, from qemu online doc it says shutdown is gracefully operation and powerdown is brutely one, but the code shows shutdown event is generated when qemu get signal from "kill", which is correct? I hope to state those clearly in the doc, so I would be appreciate if you have comments on the doc. Wenchao Xia (6): 1 block: use type MonitorEvent directly 2 qapi: rename MonitorEvent to QEvent 3 qapi: rename prefix QEVENT to Q_EVENT 4 qapi: move event defines to qapi-schema.json 5 qapi: remove var monitor_event_names[] 6 qapi: add doc for QEvent balloon.c | 2 +- block.c | 6 +- block/qcow2-refcount.c | 2 +- blockdev.c | 4 +- blockjob.c | 5 +- cpus.c | 2 +- hw/acpi/core.c | 2 +- hw/core/qdev.c | 2 +- hw/misc/pvpanic.c | 2 +- hw/net/virtio-net.c | 2 +- hw/watchdog/watchdog.c | 2 +- include/block/block_int.h | 2 +- include/monitor/monitor.h | 39 +------------------ monitor.c | 64 ++++++++---------------------- qapi-schema.json | 93 ++++++++++++++++++++++++++++++++++++++++++++ stubs/mon-protocol-event.c | 2 +- target-s390x/kvm.c | 2 +- ui/spice-core.c | 8 ++-- ui/vnc.c | 8 ++-- vl.c | 14 +++--- 20 files changed, 144 insertions(+), 119 deletions(-)