On 24.09.2013 14:03, Juan Quintela wrote:
From: Isaku Yamahata <yamah...@private.email.ne.jp>

Later is_zero_page will be used for non TARGET_PAGE_SIZE
range.
And rename it to is_zero_range as it isn't page size any more.

Signed-off-by: Isaku Yamahata <yamah...@private.email.ne.jp>
Signed-off-by: Juan Quintela <quint...@redhat.com>
---
  arch_init.c | 9 ++++-----
  1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/arch_init.c b/arch_init.c
index 18cd9a1..c72790f 100644
--- a/arch_init.c
+++ b/arch_init.c
@@ -150,10 +150,9 @@ int qemu_read_default_config_files(bool userconfig)
      return 0;
  }

-static inline bool is_zero_page(uint8_t *p)
+static inline bool is_zero_range(uint8_t *p, uint64_t size)
  {
-    return buffer_find_nonzero_offset(p, TARGET_PAGE_SIZE) ==
-        TARGET_PAGE_SIZE;
+    return buffer_find_nonzero_offset(p, size) == size;
  }

this is buffer_is_zero(p, size); maybe this function should be used.

Peter


Reply via email to