On Wed, May 15, 2013 at 11:29:29AM +0800, Fam Zheng wrote: > On Thu, 05/09 17:16, Stefan Hajnoczi wrote: > > On Thu, May 09, 2013 at 02:56:50PM +0800, Fam Zheng wrote: > > > On Thu, 05/09 08:41, Stefan Hajnoczi wrote: > > > > On Fri, May 03, 2013 at 04:00:09PM +0800, Fam Zheng wrote: > > > > > + cache = curl_find_cache(s, aio_base, aio_bytes); > > > > > + if (cache) { > > > > > + curl_complete_io(s, acb, cache); > > > > > + return; > > > > > } > > > > > > > > What is the point of the cache? Can you split it into a separate patch? > > > > > > The cache is for prefetch. Data is fetched by 256k chunks using libcurl > > > and stored in cache to fill future io request, reducing overall http > > > request overhead. > > > > That sounds like a performance optimization which is not part of fixing > > broken block/curl.c :). > > > > I didn't invent it here. Read ahead is already in curl.c, (see > BDRVCURLState.readahead_size). I don't think it's time to remove it here > either, but rename to a better name should be OK. What do you think?
Yes, that's true. Although I'm not a fan of readahead I guess it's already implemented. > BTW please keep me CC'ed when reply so that I can notice it better. Please check the headers that your email client is sending: Mail-Followup-To: Stefan Hajnoczi <stefa...@redhat.com>, Stefan Hajnoczi <stefa...@gmail.com>, kw...@redhat.com, qemu-devel@nongnu.org Stefan