On 10/04/2012 09:16 PM, Peter Maydell wrote: > On 4 October 2012 20:05, Anthony Liguori <anth...@codemonkey.ws> wrote: >> Blue Swirl <blauwir...@gmail.com> writes: >>> They can all be 64 bits, I'm just considering types. Getting rid of >>> target_phys_addr_t, pcibus_t, pio_addr_t and dma_addr_t (are there >>> more?) may be also worthwhile. >> >> Where this breaks down is devices that are DMA capable but may exist on >> multiple busses. >> >> So you either end up with a device-specific type and a layer of casting >> or weird acrobatics. >> >> It makes more sense IMHO to just treat bus addresses as a fixed with. >> >> target_phys_addr_t is a bad name. I'd be in favor of either just using >> uint64_t directly or having a generic dma_addr_t. > > I agree that we only need one type; I think it's helpful to > have a type name rather than direct use of uint64_t. dma_addr_t > doesn't seem right because most of the usage of it isn't going to > be in DMA related contexts. addr_t ?
*_t is reserved. Suggestions: phys Phys hwaddr hw_addr there are some variables named 'phys' scattered in the source, so my current favorite is hwaddr. Short and to the point. -- error compiling committee.c: too many arguments to function