"tcg/mte_helper.h" header name is a bit misleading, since it isn't restricted to TCG helpers. Rename it as "tcg/mte.h" which is a bit more generic.
Signed-off-by: Philippe Mathieu-Daudé <phi...@linaro.org> --- target/arm/tcg/{mte_helper.h => mte.h} | 0 target/arm/gdbstub64.c | 2 +- target/arm/tcg/mte_helper.c | 2 +- 3 files changed, 2 insertions(+), 2 deletions(-) rename target/arm/tcg/{mte_helper.h => mte.h} (100%) diff --git a/target/arm/tcg/mte_helper.h b/target/arm/tcg/mte.h similarity index 100% rename from target/arm/tcg/mte_helper.h rename to target/arm/tcg/mte.h diff --git a/target/arm/gdbstub64.c b/target/arm/gdbstub64.c index 64ee9b3b567..65540cffd2c 100644 --- a/target/arm/gdbstub64.c +++ b/target/arm/gdbstub64.c @@ -22,7 +22,6 @@ #include "internals.h" #include "gdbstub/helpers.h" #include "gdbstub/commands.h" -#include "tcg/mte_helper.h" #if defined(CONFIG_USER_ONLY) && defined(CONFIG_LINUX) #include <sys/prctl.h> #include "mte_user_helper.h" @@ -30,6 +29,7 @@ #ifdef CONFIG_TCG #include "accel/tcg/cpu-mmu-index.h" #include "exec/target_page.h" +#include "tcg/mte.h" #endif int aarch64_cpu_gdb_read_register(CPUState *cs, GByteArray *mem_buf, int n) diff --git a/target/arm/tcg/mte_helper.c b/target/arm/tcg/mte_helper.c index 8a6e6e4719d..b70f23e2047 100644 --- a/target/arm/tcg/mte_helper.c +++ b/target/arm/tcg/mte_helper.c @@ -36,7 +36,7 @@ #include "accel/tcg/getpc.h" #include "qapi/error.h" #include "qemu/guest-random.h" -#include "mte_helper.h" +#include "mte.h" static int choose_nonexcluded_tag(int tag, int offset, uint16_t exclude) -- 2.47.1