On Mon, 27 Jan 2025 at 23:26, Richard Henderson <richard.hender...@linaro.org> wrote: > > Signed-off-by: Richard Henderson <richard.hender...@linaro.org> > --- > target/arm/tcg/translate.h | 6 ++-- > target/arm/tcg/translate-vfp.c | 54 +++++++++++++++++----------------- > 2 files changed, 30 insertions(+), 30 deletions(-) > > diff --git a/target/arm/tcg/translate.h b/target/arm/tcg/translate.h > index 59e780df2e..6ce2471aa6 100644 > --- a/target/arm/tcg/translate.h > +++ b/target/arm/tcg/translate.h > @@ -674,7 +674,7 @@ static inline CPUARMTBFlags arm_tbflags_from_tb(const > TranslationBlock *tb) > * Enum for argument to fpstatus_ptr(). > */ > typedef enum ARMFPStatusFlavour { > - FPST_FPCR_A32, > + FPST_A32, > FPST_FPCR_A64, > FPST_FPCR_F16_A32, > FPST_FPCR_F16_A64, > @@ -692,7 +692,7 @@ typedef enum ARMFPStatusFlavour { > * been set up to point to the requested field in the CPU state struct. > * The options are: > * > - * FPST_FPCR_A32 > + * FPST_A32 > * for AArch32 non-FP16 operations controlled by the FPCR
So the reason we had "FPCR" in the names here is, as the comment notes, because the original distinction was "operations that use the 'standard FPSCR value'" versus "operations controlled by the FPCR". But I think with the profusion of float_status values we've ended up with, most of which are sort-of-but-not-entirely controlled by FPCR bits in one way or another, that the "FPCR" part of the constant name has outlived its usefulness. So I'm happy with renaming these to be shorter. thanks -- PMM