On 8/22/2024 3:00 PM, Yoochan Jeong wrote:
On 8/22/2024, Jeuk Kim wrote:
On 8/21/2024 11:32 AM, 정유찬 wrote:
   static void ufs_send_query(QUfs *ufs, uint8_t slot, uint8_t query_function,
                               uint8_t query_opcode, uint8_t idn, uint8_t index,
+                          uint8_t selector, uint32_t attr_value,
We use ufs_send_query() not only for attributes, but also descriptors
and flags.

Please rename `attr_value` to `value`.


I think this parameter name is okay, because this "value" in UPIU is
only used when writing attributes. Writing flags do not require an
actual value, and descriptor data will be stored in data segmentation
area.

Okay. That's reasonable.


We might need to check condition here that `query_opcode !=
UFS_UPIU_QUERY_OPCODE_WRITE_DESC`, since

it is not implemented yet.

in ufs_exec_query_write function in ufs.c, it already checks
if it is trying to write a descriptor. Is there any particular
reason that we should check it here in advance?

You're right. We don't need to check it here.



Reply via email to